Incoming calls drops after less than a minute - after module updates

Hi, I’m running FreePBX Distro (up to date to a month ago) and I think it started since I updated all the FreePBX Modules (not sure about it) but my incoming calls drops after less than a minute. Outgoing calls can keep for hours no problem.

CDR Report doesnt show anything unusual:
2017-01-04 13:56:11 1483556171.98 "2255:" <> 1**** Dial 710 ANSWERED 00:34

The incoming route is directly set from the inbound route to my chan_sip extension, no IVR or anything in between.

Asterisk version?

Asterisk version: 13.12.1
FreePBX version:
Distro installed: FreePBX-64bit-10.13.66

Upgrade Asterisk to current with

yum upgrade
fwconsole restart

*edit - after pondering this a bit, I think that perhaps the above may not fix (but certainly won’t hurt), the Asterisk bug I was thinking of was in the 13.11 branch.

Thanks, now I’m running 13.13.1, but incoming calls still drops after less than a minute (around 36-38 seconds).

Double check your settings in Asterisk SIP settings and then provide a sanitized call trace.

… and look at the UDP expire options in your firewall. We’ve seen cases like this where the expire/keep-alive on the router was set too low.

Thanks guys but I really don’t understand enough to see if there’s a problem in the SIP Settings (everything looks normal to me, but I don’t really know what I’m doing… RTP timeout is 30 and RTP hold is 300 but I’m not sure what it is.

Also I don’t know what is sanitized call trace, I didn’t see anything about it in SIP Settings.

About the Firewall - I’m only using the pre-installed IPTables, I’m not using the firewall module, and my hosting provider doesn’t think it comes from their side.

The different configurations to Chan_SIP and PJSIP also makes me question if the problem started when I moved my extensions to use Chan_SIP instead of PJSip that I used at the beginning, and I also switched the default port between them (5060 and 5160, to make the Chan_SIP run on the default SIP port). I guess that I should revert my changes just to see if it fixes this issue.

so weird…

chan_sip on 5060 - fall
chan_sip on 5160 - not falling

pjsip on 5060 - not falling
pjsip on 5160 - not falling

the solution is i’ll just keep it on the default ports the Distro came with, but just out of curiosity, does anyone has a clue what caused that?

Are you restarting Asterisk after making changes to bind ports?

fwconsole restart

*** UPDATED ***

Unfortunately the fwconsole restart doesn’t solves the issue.
Now with the default ports, I’m facing my original issues that made me switch the ports:

I changed the ports because when I’m using chan_sip on 5160 (default setting) only the caller hear me, and I can’t hear them. That doesn’t happens with port 5060 (but there the call drops after less than a minute).

Another thing that’s not related, I’m traveling in europe right now and I’m using Vodafone as my cellphone provider. They’re blocking VoIP connections, do you have any workaround to get it work on their network?

One-way audio is almost always a NAT problem. Chances are that your firewall is not passing all the traffic you need to your PBX.

AFAIK, the only firewall I have is the IPTables that came pre-configured with the FreePBX Distro.
Any idea what may cause the NAT problem with it?
The Firewall Module is OFF and the hosting provider don’t think their configurations causes any issues…

Thanks again!