Incoming calls don't work from some phone networks


I have a very strange problem with incoming calls. Calls from some phone network providers can call in without any problems some others immediately hear the busy tone. My Trunk provider says it’s not their fault. Can anyone give me a hint what the problem could be?

The Trunk settings are:
PEER Details


FreePBX Distro: 3.211.63-103.211.63-10

The interesting thing is, that calls which come from the phone networks provider which don’t work also don’t generate anything in the logs so it looks like they are never arriving at the local asterisk server.

Many thanks for your help,

Please be more specific as to what you consider is a “phone network provider” and how those differ from your “Trunk provider”.

Thanks for your reply.
With “phone network provider” I mean phone companys. For example with my mobile phone, which is from the provider 3, I can call in - my colleague which has his mobile phone contract with T-mobile only hears the busy tone.

I had the same problem when I first implemented My system about 7 years ago, and as I remember It too involved cell providers. It turns out that those companies had not put routes to our DID’s, which consisted of the NXX 801 which had not been previous previously used in the 601 NPA, and some phone companies didn’t know about it. When a customer of one of those service providers called 601-801-XXXX, their provider thought it was an invalid number. Several days later they started working. Don’t know if the calls I made to various providers helped, or everything sorted itself out in the normal course of things.


I’m having similar issues with VoicePulse. They are telling me the SIP Invite is being sent, but that there is no response. I can’t see anything in the sip debug logs. Very strange. Other providers are working fine (one’s without registrations).

I can see that my firewall has an open state. Next will be to use a packet sniffer and see if the packets are even reaching the pbx.

I’ve also put the provider’s IP addresses on the fail2ban whitelist (even though it didn’t show any banned ips).


for me the problem solved itself on it’s own. I didn’t change anything on my site but 2 days later it was working again. I still suspect that it was the trunk provider’s problem any they silently without admiting it, solved it.

My provider magically came back as well. They sent me copies of the SIP invite messages they said they were sending so I assumed it was on my end. I was about to use a packet capture when it sorted itself…