Incoming calls do not work on SIP trunk

Hello

I have SIP trunk to a company which supports 3CX. Now I want connect FreePBX distro (latest version) to the trunk. Unfortunately the company does not provide much details. All I know:

VoIP ID: 7483xxx
Password: xxxxx
SIP registration URL: sip.3cx.voipworld.org
NAT proxy URL: nat.3cx.voipworld.org

I have congifured one inbound, one outbound routes and one trunk.

Trunk:
Trunk Name: voipworld
Outbound CallerID: 08723324xxx

Asterisk is registered:
Host dnsmgr Username Refresh State Reg.Time
sip.3cx.voipworld.org:5060 N 7483xxx 105 Registered Wed, 06 Feb 2013 16:34:18

Outgoing calls work fine but I can not receive incoming calls. Robot on provider side tells there is an error and I see nothing in SIP debug on Asterisk. Guys from support told me “You need to setup the outbound proxy of nat.3cx.voipworld.org (Port 5060) for incoming calls to route.” But they give no other info because they do not support Asterisk/FreePBX. I added outboundproxy=nat.3cx.voipworld.org to incoming details but it did not help.

Any ideas?

Thanks.

Try replacing peer with user in the USER details.

Unfortunately it did not help.

Current settings of USER Details:
type=user
insecure=invite
context=from-trunk
outboundproxy=nat.3cx.voipworld.org

Frankly trying to debug service provider settings is a hair-pulling exercise.

Normally (and don’t take hope from that)
I put in the userID and secret in the user section as well.

Normally the registration string is the worst part. some providers want didnumber:user:[email protected]
others may not.
I notice your “account” looks like a 7 digit number - like a phone number without the area code - I assume you have a DID number if you are receiving calls.

Finally several settings might trip - example: some providers don’t wish you to “qualify” - by default I don’t know what your system does…

I can go on for quite a while with this (yes, I’ve had my share) but it doesn’t help so I’ll leave it as

Sorry but with a bit of luck, you might find some other user who was successful at connecting. Might be a forum on the service provider’s website with users that might have been successful.

This is one area I feel could be greatly improved in FreePBX. Right now setting up and troubleshooting trunks is much more difficult than it needs to be imho.

Perhaps a module like endpoint manager for trunks.

I have progress. I connected Linphone to the provider and can originate calls and receive incoming calls. Linphone settings:

SIP identity: sip:[email protected]
SIP proxy address: sip:sip.3cx.voipworld.org
User ID: 7483xxx
Password: xxxxx

But FreePBX with settings above does not work.

What is wrong in the settings?

Finally I got incoming calls working.

Settings:

Thank you guys for help.

1 Like