Incoming callers don't hear ringing as Asterisk rings the extensions

I have most everything working really well with FreePBX and Asterisk – I love it! However, my friends and family (and I’ve experienced it as well) say that they don’t hear ringing when they call. They hear dead silence (or sometimes 1 ring) until I pickup the line and start talking.

My guess is that asterisk immediately answers the SIP request from the trunk and is not providing a ringing sound to the trunk as the extensions ring.

I have FreePBX 2.5.1 with 1.4.25 Asterisk – and I use a SIP provider, Vitelity, for my incoming calls.

I feel like there is a simple solution to this, but after hunting around the settings I am unable to find the magic fix.

Any tips or help would be greatly appreciated!


For anyone else struggling with this issue, here is what I found. I later learned that the problem only happened when I used a RING GROUP as the destination for the incoming route. On the ring group settings page there is an option “Play Music on Hold” that needs to be set to “RING”.

Personally I feel as that option is misnamed – because it represents what you want played to the user during the time the extensions are ringing.

– Joe

Well I wouldn’t call it mis-named. Probably either a bug or a user mis-configuration.

I believe I have seen some modes where ring groups do that when set to MoH but I don’t recall anyone filing a ticket with the detailed configuration provided to regularly reproduce it.

Alternatively, you may want to confirm (or state here) that indeed you do have MoH working properly on your system in other scenarios, which if so, probably rules out user mis-configuration :slight_smile: