Incoming call - several numbers, recognition of the number to be called from the client level (Slican exchange)


(Templeusz) #1

I have an account with a SIP operator with 3 telephone numbers (221111111, 221111112,221111113)
I added this SIP account to the FreePBX VoIP switchboard and created 3 extensions (1008,1009,1010)
In the Inbound routes tab, I added 3 entries.
DID: 221111111 CID:Any Description: phone8 Destination: Extensions: 1008 phone8
DID: 221111112 CID:Any Description: phone9 Destination: Extensions: 1009 phone9
DID: 221111113 CID:Any Description: phone10 Destination: Extensions: 1010 phone10

Using 3 computers (3cx application) I logged into 3 VOIP accounts (1008,1009,1010)

Effect: I call 221111111, the phone on computer 1 (account 1008) rings
I calling 221111112 the phone is ringing on computer 2 (account 1009)
I calling 221111113 the phone is ringing on computer 3 (account 1010)

So everything works fine

What I need to achieve:
How it worked before:
I have 3 phones connected to the Slican telephone exchange (phone a, phone b, phone c)
The data from the previous VOIP provider is entered in the central office only 1 SIP account with 3 numbers phones.
I called the number “221111111” and"phone a" rang
I called the number “221111112” and “phone b” rang
I called the number “221111113” and “phone c” rang

Currently how it works:
I have an account with a SIP operator with 3 telephone numbers (221111111, 221111112,221111113)
I added this SIP account to the FreePBX VoIP switchboard and created 1 extensions (1008)
In the Inbound routes tab, I added 3 entries.
DID: 221111111 CID:Any Description: phone8 Destination: Extensions: 1008 phone8
DID: 221111112 CID:Any Description: phone8a Destination: Extensions: 1008 phone8
DID: 221111113 CID:Any Description: phone8b Destination: Extensions: 1008 phone8
On the slican telephone exchange, I change the SIP login data from the previous VoIP provider to new data (FreePBX - account 1008)

I called the number “221111111” and “phone a” rang
I called the number “221111112” and “phone a” rang
I called the number “221111113” and “phone a” rang

I suspect that the freepbx control panel does not provide information about the DID and something needs to be changed in the extenisions settings, but I don’t know what.


#2

FreePBX does not send the called number when calling an extension.

You need to create one Trunk and have the Slican PBX register to that. Assuming a pjsip trunk, set it up with Registration Receive and Authentication Inbound. The relevant Inbound Route(s) from the SIP provider should have the Destination be the Slican trunk.

If you still have trouble, at the Asterisk command prompt, type
pjsip set logger on
make a failing incoming call, paste the Asterisk log for the call at pastebin.freepbx.org and post the link here.


(Templeusz) #3

thanks, using trunks (pjsip) instead of extensions gave the expected effect :slight_smile:
The DID number on Slican’s central is correctly visible.

Is it safe to use trunks instead of extensions to connect clients?
As far as I know, you should enter VoIP providers in the Trunks tab in FreePBX, while customers should be entered in the “Extensions” tab.
However, here I added the client to the trunks tab which should be used for VoIP providers


#4

Nothing is completely safe. Systems have bugs, configurations have errors, and credentials are stolen by social engineering.

However, I don’t believe that using a trunk rather than an extension in this setup is any less safe. If your clients have static IP addresses, setting up your firewall to allow only authorized addresses to connect would provide additional security.

You could also implement restrictions in FreePBX such as allowing only specific countries to be called, limiting the number of simultaneous calls, etc.


(Templeusz) #5

Incoming calls work fine, outgoing calls are not working.

https://pastebin.freepbx.org/view/embed/7dd87da5/


#6

You need to change the Context for the trunk to from-internal (what the extension had) or a custom context (if you want to implement extra security or special features).

With the context set to from-internal, you can still use your Outbound Routes to implement restrictions.


(Templeusz) #7

thanks changing context helped


(Templeusz) #8

There is one more minor problem, in the CDR Reports tab, in the case of incoming calls that are directed to trunk 108, the Destination item displays “tdial”, not “1008”