Incoming call not routed to sip-device

I just hear “The number you have dialed is not in service…”

I’ve just installed AsteriskNOW, that uses FreePBX. I use the norwegian voip provider Phonect(.no).

I can call out and between my two SIP-devices fine. Incoming is the problem. I had the non-FreePBX earlier version of AsteriskNOW where everything worked fine.

Here is the log:
– Executing [[email protected]:1] GotoIf(“SIP/194.6.238.82-b781dab8”, “0?from-trunk||1”) in new stack
– Executing [[email protected]:2] Set(“SIP/194.6.238.82-b781dab8”, “TIMEOUT(absolute)=15”) in new stack
– Channel will hangup at 2009-04-09 18:55:07 UTC.
– Executing [[email protected]:3] Answer(“SIP/194.6.238.82-b781dab8”, “”) in new stack
– Executing [[email protected]:4] Wait(“SIP/194.6.238.82-b781dab8”, “2”) in new stack
– Executing [[email protected]:5] Playback(“SIP/194.6.238.82-b781dab8”, “ss-noservice”) in new stack
– <SIP/194.6.238.82-b781dab8> Playing ‘ss-noservice’ (language ‘en’)

[Phonect]
host=srv.service.phonect.no
username=55544433
secret=mypassword
insecure=port,invite

The above is from what I wrote in the “Outgoing settings” of SIP-trunk settings. Username and password not real.

On the “Incoming settings”-section of SIP-trunk settings, I put in nothing in the User context and user settings. I inserted a string-version of the above login in the “Register String”. I did try once to set a user context-name and the same login-info as above, but that did not change anything. If I remove the “Register String”, I cannot make incoming calls at all.

From the previous non-FreePBX installment, I had to include the following in the general-section of sip.conf (which now put in the file sip_general_custom.conf):
externip=my.ip.address
nat=yes
useragent=Phonect_Asterisk

I am very much a newbie. Appreciate any help! Thanks!

Frode

in the general settings tab have you enabled the “Allow Anonymous Inbound SIP Calls?” You provider is by default considered an anonymous inbound uless you have coded the specific IP’s.

Thanks a lot :slight_smile: