Inbound yes, outbound drops after 6 seconds

We have two office using one phone server. The internal phones can make and receive calls, the external phones, 4, can receive but outbound drops after 6 seconds. Can you please give me some ideas on what to look for to solve this issue. There is a vpn between the offices, ports 5060 and 10000-20000 are opened. External phones have registered. I am at a loss for ideas. HELP

This is always a nat issue. Basically a timer is expiring. This is with signalling meaning 5060 is where the issue is happening. (no audio would likely be 10000-20000)

Make sure sip alg is disabled on all routers. look at the debug in the asterisk CLI to see what timer is expiring and try to bump the time up if it is because of a delay.

I am new to asterix cli so what command would you use?

asterisk -rvvvvvvv

or go into the cli and
sip debug <sip endpoint> on

I’m interested in this sip debug command but when I enter it say - sip debug 121 on I get an error message. Am I putting it in wrong? Thanks

sip set debug peer nnn

sip set debug ip …

is this asterisk command?

would that be a timer on the external phone?

Here is my issue, gs2100 registers to server, inbound calls come through, but outbound drops after 5 seconds. This is a phone outside of the phone server. This is the error i get when call is established and then dropped:

[2017-11-22 09:33:13] WARNING[2455] chan_sip.c: Retransmission timeout reached on transmission [email protected] for seqno 11 (Critical Response) – See
Packet timed out after 6399ms with no response
[2017-11-22 09:33:13] WARNING[2455] chan_sip.c: Hanging up call [email protected] - no reply to our critical packet (see

There is a vpn between offices, the required ports are forwarded, NAT is on with the device. I am running out of ideas because I have tried and checked everything I have read.

Turn on the sip debug, you will be able to see where the routing is going awry

I found that the network in question wasn’t added to the local networks under sip settings. It used to work but possible a module update changed something. Once I added the network to sip settings, it worked.

I have a similar problem but the other way around. I’m using Zulu on my laptop that I connect back to our main office via openVPN where the PBXact is. It registers fine and I can call out fine with both way audio. But on inbound calls there is no audio either way. I answer the call in Zulu and it seems to work but there is just no audio at all. It doesn’t disconnect the call though. I checked our office firewall settings and I’ve allowed all traffic through VPN. I also added the VPN network to the local networks in PBXact but it didn’t help :confused: not sure what else to try… I tried looking through the asterisk cli during an inbound call but I don’t see why there is no audio - I’m probably missing something.
Any ideas?

Wish there was an advanced course for FreePBX/PBXact troubleshooting, not just the basic ones :wink:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.