Inbound working. Outbound not after 12 hours


(Northdesign) #1

So I’ve been trying to figure this out all day. Thanks in advance for any help! I installed a clean install of FreePBX 15.0.16.72 running Asterisk 16.11.1.

I set up my trunk for Vitelity.

vitel-outbound
type=friend
dtmfmode=auto
username=myusername
secret=mysecret
fromuser=myusername
trustrpid=yes
sendrpid=yes
context=from-trunk ; (this could be ext-did or from-pstn as well)
canreinvite=no
host=outbound.vitelity.net
qualify=yes

vitel-inbound
type=friend
dtmfmode=auto
username=myusername
secret=mysecret
context=from-trunk ; (this could be ext-did or from-pstn as well)
insecure=port,invite
canreinvite=no
host=inbound2.vitelity.net
qualify=yes

Inbound calls are coming in fine.

Outbound calls are getting sent to the congestion message.

When I look at the SIP registrations under Reports-Asterisk Info-CHANSIP it would appear that my install is connecting with both Vitelity servers.

When I look at the host registration further down, I’m only getting the inbound host.

After 12 hours of researching and trouble shooting I need help figuring out what I’m doing wrong.

Thanks in advance.

Regards,
David


#2

In the peer details for the outbound trunk, add
fromdomain=outbound.vitelity.net
and make sure that the number and caller ID you are sending both start with the country code.

If you still have trouble, at the Asterisk command prompt type
sip set debug on
make a failing test call, paste the relevant section of the Asterisk log (redacted) at pastebin.freepbx.org and post the link here.


(Northdesign) #3

Thanks Stewart1! I’m only technical enough to understand most of this but still learning.

So adding fromdomain=outbound.vitelity.net didn’t seem to help. When you say make sure the caller ID both start with the country code do you mean <14194647679>. I put that in the Outbound CallerID field. I’m in the US.

Finally, I think I might have somehow killed my full log file by clicking the trash can on the Astrisk Log Files GUI page. How can I get it to start generating the full log again?

Sorry but I’m a noob. This process seemed much easier the last time I set this all up from scratch.


#4

There is apparently a recent bug affecting logs for some people, but I don’t know the details. If nothing logs when you attempt a call, go to Settings -> Asterisk Logfile Settings -> Log Files and check that for both console and full, Debug, Error, Notice, Verbose and Warning are turned on. If no luck, reboot the server and check again. If still no luck, please open another thread on this logging issue.


(Northdesign) #5

So, I figured out my registration issue. I didn’t have the password entered in correctly. I copied the guidance from the Vitelity support page thinking the password was encrypted since it was displayed as E******0! So of course when I actually entered my actual account secret in there it worked.

I’m an idiot. That’s what I get for working on this until 2am last night.

Thanks for your help.


#6

Glad that you got it working. Are calls being logged again?


(system) closed #7

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.