Inbound thinks it has picked up calls when it hasn't

My configuration was working, but it appears that some time ago it had stopped answering inbound calls. For my HW config I have an ATA FXO (HT813) and before that I splitter to a POTS phone for troubleshooting. Inbound calls continue to ring the POTS phone, but FreePBX believes that it has picked up the call when it hasn’t.

https://pastebin.freepbx.org/view/3b6e8128

Again, I haven’t made any configuration changes, but I did have auto-update configured for modules and it has been several months since I’ve looked at the system.

Any assistance on where I should be looking would be greatly appropriated.

At this level of logging, it appears ok. We can try a SIP trace next; if that also looks normal we can use the HT syslog features to troubleshoot further.

However, first confirm that outbound calls through the HT trunk are working properly. If not, that is likely easier to debug.

For the SIP trace, at the Asterisk command prompt type
sip set debug on
make another failing inbound call and paste the new log.

From line 203

[2021-09-19 13:45:31] VERBOSE[4822][C-00000001] pbx.c: Executing [[email protected]:7] AGI("SIP/815XXXXXXX-00000000", "agi:[//127.0.0.1/dialparties.agi](https://127.0.0.1/dialparties.agi)") in new stack
[2021-09-19 13:45:31] WARNING[4822][C-00000001] res_agi.c: Connecting to '127.0.0.1:4573' failed for url 'agi:[//127.0.0.1/dialparties.agi'](https://127.0.0.1/dialparties.agi'): Connection refused
[2021-09-19 13:45:31] WARNING[4822][C-00000001] res_agi.c: Couldn't connect to any host.  FastAGI failed.

The fastagi daemon is not running/responding. I don’t think I’ve ever seen this reported before. You might be able to get it running again with

fwconsole pm2 --restart core-fastagi

or by doing a complete fwconsole restart.

I had seen that but an Answer for the trunk was executed on line 73 and the OP said that the HT didn’t trip the ring.

On the assumption that there is only one problem, do you see how these issues could be related?

FastAGI; This appears to not be the issue;

https://pastebin.freepbx.org/view/9dd17f1e

Sip debug;

https://pastebin.freepbx.org/view/b3e52faa

It appears that Asterisk responded to the incoming INVITE with a proper 200 OK and the HT replied with a proper ACK (which Asterisk must have treated as valid, because it did not retransmit the 200 OK).

So, why didn’t the HT trip the ring? Possibly, it’s something simple like a bad connector or cord. Please confirm that outbound calls via the HT trunk are working properly, and you have tried rebooting the HT. Also, post a screenshot of the HT Status page, refreshed just after the IVR announcement starts playing.

Good call on checking outbound calling, I must need more coffee;

https://pastebin.freepbx.org/view/7b1ceed9

… from the phone, it doesn’t do anything… just silence.

This is starting to look like a hardware failure in the HT. With luck, it’s just the power adapter and you have a compatible one from another device you can use to check.

The log shows an apparently OK call lasting 26 seconds. Do you you know whether the called phone rang? What happens when you pick up the bridged POTS phone while the call is apparently in progress?

Screenshot

No, the called number does not ring. Interestingly the FXO LED on the HT813 does flash when the outbound call is attempted. Picking up the bridged POTS line produces dial-tone.

At this point, I’m going to assume that the HT has taken an ESD strike. I’ll report back after the new one comes in tomorrow.

Unfortunately, this looks like a hardware failure to me – the HT shows the line taken off hook but sufficient loop current did not flow.

Try with a different cord (and different wall jack, if applicable). Though unlikely, it’s conceivably a firmware corruption issue; try reloading it. Possibly, a power module issue (try a spare or check voltage and ripple when trying to call).

If your POTS service has call forwarding, you could redirect calls to a SIP trunk. For outbound, you can probably find a trunking provider that allows you to send the POTS number as outbound caller ID.

Replacing the HT813 worked. While I don’t see obvious damage to the old HT813’s board, I’m pretty sure that it had taken an ESD strike. So Stewart1, where do I send the beer?

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.