Inbound DID with a pattern match

Hi,

For some reason this isn’t working… I have my default incoming DID going to a extension - works fine :slight_smile:

I now have a range of DIDs I want to send to a ring group - this, doesn’t want to work!

In my DID I have: 02152188[5-9]X The idea is that it matches any number in that range (5 to 9, 0 to 9). When debugging this, the asterisk logs indicate that it doesn’t match any patterns, even though the DID coming in, is in fact 0215218855 (as per example).

Does incoming DIDs with pattern matching work?? I have the latest version of FreePBX running with no out of date modules etc…

– LOG –
[Jul 14 13:31:26] – Called g2/0215218855
[Jul 14 13:31:26] – Accepting call from ‘8628’ to ‘0215218855’ on channel 0/1, span 1
[Jul 14 13:31:26] – Executing [[email protected]:1] Set(“Zap/1-1”, “DID=0215218855”) in new stack
[Jul 14 13:31:26] – Executing [[email protected]:2] Goto(“Zap/1-1”, “s|1”) in new stack
[Jul 14 13:31:26] – Goto (from-zaptel,s,1)
[Jul 14 13:31:26] – Executing [[email protected]:1] NoOp(“Zap/1-1”, “Entering from-zaptel with DID == 0215218855”) in new stack
[Jul 14 13:31:26] – Executing [[email protected]:2] Ringing(“Zap/1-1”, “”) in new stack
[Jul 14 13:31:26] – Executing [[email protected]:3] Set(“Zap/1-1”, “DID=0215218855”) in new stack
[Jul 14 13:31:26] – Executing [[email protected]:4] NoOp(“Zap/1-1”, “DID is now 0215218855”) in new stack
[Jul 14 13:31:26] – Executing [[email protected]:5] GotoIf(“Zap/1-1”, “1?zapok:notzap”) in new stack
[Jul 14 13:31:26] – Goto (from-zaptel,s,8)
[Jul 14 13:31:26] – Executing [[email protected]:8] NoOp(“Zap/1-1”, “Is a Zaptel Channel”) in new stack
[Jul 14 13:31:26] – Executing [[email protected]:9] Set(“Zap/1-1”, “CHAN=1-1”) in new stack
[Jul 14 13:31:26] – Zap/32-1 is proceeding passing it to SIP/8628-b793d050
[Jul 14 13:31:26] – Zap/32-1 is ringing
[Jul 14 13:31:26] – Executing [[email protected]:10] Set(“Zap/1-1”, “CHAN=1”) in new stack
[Jul 14 13:31:26] – Executing [[email protected]:11] Macro(“Zap/1-1”, “from-zaptel-1|0215218855|1”) in new stack
[Jul 14 13:31:26] – Executing [[email protected]:12] NoOp(“Zap/1-1”, “Returned from Macro from-zaptel-1”) in new stack
[Jul 14 13:31:26] – Executing [[email protected]:13] Goto(“Zap/1-1”, “from-pstn|0215218855|1”) in new stack
[Jul 14 13:31:26] – Goto (from-pstn,0215218855,1)
[Jul 14 13:31:26] – Executing [[email protected]:1] NoOp(“Zap/1-1”, “Catch-All DID Match - Found 0215218855 - You probably want a DID for this.”) in new stack

As you can see, it matches the DID to the ‘Catch All’ rule, and not to the incoming DID with the range.

All other DID’s seem to be working fine on my inbound routes, it’s just DIDs with a pattern, that doesn’t work

Try setting your DID match pattern to:

_02152188[5-9]X

Note the leading underscore.

Works, thank you!

Don’t know how I overlooked that one…