Inbound Calls

Hello,

Can someone help me? I am having inbound call trouble. I am receiving the message 'The number you are trying to reach is not in service" Does someone out there know how to fix this? Thanks,.

you need to provide some real information to get some real help. Your request is the same thing as me saying my car will not start please fix it.

For starters, who’s distro did you use to build your system? if not a distro build then who’s build instructions did you use? What have you programmed already or did you just load the system and then try and call in without programming any extensions or routes?
Type of trunks?
do you have DID?
Have any logs you can show us?
and at least 50 other questions I could keep typing.

The reason you are getting the message is that the system too kthe call and looked through it’s routing table and could not find a destination to route the incoming call to, so since it does not know what to do with that call it plays that message (i.e. the phone number you dialed is no longer/not in service as it can’t find a service route for that number to a valid phone.

We are all great minds, just not great mind readers.

Here is some background…

I am running freePBX 2.2 and my line supplier is bandwidth.com. I have all the inbound routes setup. Here are my inclomg settings:

context=from-trunk
host=4.79.212.236&216.82.224.202&216.82.225.202
secret=
type=user

Now nothing has changed, but over the last week they just stop working and Bandwidth says that have done nothing on there end. I restored my last month’s backup and still get the same error. I would think that If something had changed in my system over the last week that restoring would correct it, but it has not.

Please let me know what else I can send you. Thanks.

Well I hate to say it but Bandwidth.com is probably lying. They changed something it might be minor in the scheme of things but it effected your system.

One possiblity is that they might have announced 6-8 months ago that a host was going to be taken off line and to replace it in your config with another, then just last week they did take it off line causing the issue, etc.

Double check the support and notifications section of their site to see. But I’ll also guess you are using a earlier version of asterisk 1.2 so they might have adjusted/added a signaling parameter that the later versions support and yours might not.

I thought that was it, but I am having a hard time convincing them that this is what is going on. So where do I begin? I have spent the last week checking every line of code and found nothing wrong on our end, be cannot seem to be able to convince them that they have something wrong on theirs.

Any suggestions on how to convince them? Should I upgrade my Asterisk pbx to the latest release or will that make things worst.?

Any suggestions…please!

Start by insisting that everything has stayed the same for the last 3 weeks. You’ve even restored from a backup of three weeks ago and it still does not work. So something on their end has to have changed…

I have insisted this time and time again and here is what their trace shows: (does this help?)

U 2008/10/13 18:05:58.193675 216.82.224.202:5060 -> 70.63.224.58:5060
INVITE sip:[email protected]:5060;transport=udp SIP/2.0.
Record-Route: sip:216.82.224.202;lr;ftag=VPSF506071629460.
Record-Route: sip:4.79.212.229;lr;ftag=VPSF506071629460.
Via: SIP/2.0/UDP 216.82.224.202;branch=z9hG4bKca4c.1a7be205.0.
Via: SIP/2.0/UDP 4.79.212.229;branch=z9hG4bKca4c.648d45d.0.
Via: SIP/2.0/UDP 4.68.250.148:5060;branch=z9hG4bK506071629460-1207147391919.
From: sip:[email protected];isup-oli=0;tag=VPSF506071629460.
To: sip:[email protected]:5060.
Call-ID: [email protected].
CSeq: 1 INVITE.
Contact: sip:[email protected]:5060;transport=udp.
Max-Forwards: 67.
Content-Type: application/sdp.
Content-Length: 171.
Remote-Party-ID: sip:[email protected];party=calling;screen=yes;privacy=off.
.
v=0.
o=- 1223921157 1223921158 IN IP4 4.68.248.196.
s=-.
c=IN IP4 4.68.248.196.
t=0 0.
m=audio 62158 RTP/AVP 0 18 101.
a=rtpmap:101 telephone-event/8000.
a=fmtp:101 0-15.

U 2008/10/13 18:05:58.225168 70.63.224.58:5060 -> 216.82.224.202:5060
SIP/2.0 404 Not Found.
Via: SIP/2.0/UDP 216.82.224.202;branch=z9hG4bKca4c.1a7be205.0;received=216.82.224.202.
Via: SIP/2.0/UDP 4.79.212.229;branch=z9hG4bKca4c.648d45d.0.
Via: SIP/2.0/UDP 4.68.250.148:5060;branch=z9hG4bK506071629460-1207147391919.
From: sip:[email protected];isup-oli=0;tag=VPSF506071629460.
To: sip:[email protected]:5060;tag=as5c247caa.
Call-ID: [email protected].
CSeq: 1 INVITE.
User-Agent: Asterisk PBX.
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY.
Contact: sip:[email protected].
Content-Length: 0.

…before arguing with your telco.
For a start, they get to argue with people all day, so they’ll be better at giving you reasons why it’s your fault instead of investigating.
Secondly, you need to determine whether the calls are hitting your box or not.

When you’re in the freepbx CLI, do you see call negotiation when you call your number ?
If yes, then start checking your box first.
If no, have a chat with your telco.

Typically (and this is dependant on where you are in the world), if you get ‘all circuits are busy’, you’ve hit FreePBX. If you get 'The number you are trying to reach is not in service", that is typically a telco message, indicating call lookup/termination failure.

Can you make outbound calls ?
Can you call that extension from another extension ?

You could also prove it out of Freepbx, by configuring a softphone with the same login details for your VSP, unplug freepbxfrom the network temporarily, and then making calls in to your number and see if the softphone rings.
If it doesn’t, then it’s either network or telco related.
If it does ring, then bad luck, it’s freepbx related, and you’ll have to investigate further.

However, at this point, you need to determine where to start your investigation.

I have tested everything but the softphone, which is a good idea, but I have not been very successful in getting softphones to work.

I can make outbound calls and can dial extensions within the office from one line to another, so I believe the pbx is dialing internally.

When I dial any of my lines from an outside phone (cell or other) I get:

“you have reached a number that has been disconnected or is no longer is servicer”

But when I dial any of my numbers from within a phone in the office I get a constant ring that seems to go nowhere.

Let me know your thoughts while I work on the softphone issue.

Thanks,

in your General Settings in FreePBX and make sure the Allow Anonymous SIP calls is set to Yes.
By default it’s set to No…

I’d also strongly suggest updating your PBX to at least 2.4, as there’s some substantial improvements in some of the modules.

but still no go. I was planning to upgrade last weekend whne things went bonkers. I know I don’t want to upgrade before I can get the syste working again and compound the problem.

Any futher suggestions? I’m at my wits end…

When you’re in the freepbx CLI, do you see call negotiation when you call your number ?

Did you try this ? Did anything show up ?
How did the softphone test go ?

Do I have to login in at the console or can I see this from the GUI? If so, how? I am still learning. Thanks.

You’ll need to access the CLI, by typing asterisk -r
You’ll find a lot of information with scroll up the screen when a call hits the box, but it’s invaluable when troubleshooting.
Post your result on here, so we can see if there’s handshaking issues

I To am having the same problem. When calling one of my DIDs from an extension, I get the “All circuits are busy now” message. When I call from my cell I get, “The person you are trying to reach is not accepting calls at this time”. Extensions will call each other just fine, as well as outgoing calls working just fine. Can’t help but think that there is something that needs to be corrected in my trunk User Details. I use Carriers @ icall (Termination.com) thier setup instructions are as follows:

Sample Asterisk config files
sip.conf
In the top section of your sip.conf, enter the following:
register => cust_xxxxxxxxx:[email protected]:5060
At the end of your sip.conf file, add the following:
[icall]
type=friend
host=gw01-car.dal.us.icall.net
context=icall_in
username=cust_auroraman
secret=voiporama
disallow=all
allow=ulaw
allow=alaw
allow=gsm
insecure=very
canreinvite=no
qualify=no

extensions.conf
Add the following lines to your outbound context:
exten => _1NXXNXXXXXX,1,Dial(SIP/${EXTEN}@icall)

The following lines will simply answer calls for any of your DIDs, you’ll probably want to extend the functionality.

[icall_in]
exten => 5612442775,1,Answer
exten => 5612442780,1,Answer

That’s it. These people offer no help as to where to put this info or where to find these config files. Config edit in the web admin GUI doesn’t show these files. I t instead shows SIP_CUSTOM_CONFIG and EXTENSIONS_CUSTOM_CONFIG. i HAVE PASTED THE [ICALL_IN] lines in both of these and even included them in my user details i the trunks setup.

Hellllp!

Hi T.Pratt,
You really should consider starting your own thread, as it’s considered slightly rude to hijack someone else thread, even it appears you share the same problem.

I’d suggest checking your inbound routes are set up correctly initially, and are pointing to a valid extension (ie: one that is active). Also, check your call negotiation in the CLI, and check that it’s not trying to send the call off somewhere odd.

If you’re new to FreePBX, check out the documentation on this site, or hop over to Nerd Vittles and check out the excellent documents over there.

My Apologies for barging in. As soon as I figure out how to start a new thread I will do so.
Again my apologies for my breach of forum etiquette.

T. Pratt

I can see traffic when I call from extension to extension, but none when I call from an outside line. I’m still getting the same general message.

Like you said there is a lot on the screen so how do I send the results to you?

Pratt, it’s really not that hard (but for some reason many can’t find it). On the left hand side of this web page, select forums. When that page loads you’ll see it right above the forum selections.

Not sure if this is still an issue, but you’ll find all the call negotitations in /var/log/asterisk/full
Don’t post the entire file here, just make some sample calls inbound, and then paste the details here.
We should be able to see what the system is doing, or if the system is even getting the call.

What you should see, when a call comes in, is something similar to below:

Verbosity is at least 3
– Executing [0945*****@from-sip-external:1] NoOp(“SIP/0945*****-08ecf9c0”, “Received incoming SIP connection from unknown peer to 0945*****”) in new stack
– Executing [0945*****@from-sip-external:2] Set(“SIP/0945*****-08ecf9c0”, “DID=0945*****”) in new stack
– Executing [0945*****@from-sip-external:3] Goto(“SIP/0945*****-08ecf9c0”, “s|1”) in new stack
– Goto (from-sip-external,s,1)
– Executing [[email protected]:1] GotoIf(“SIP/0945*****-08ecf9c0”, “1?from-trunk|0945*****|1”) in new stack
– Goto (from-trunk,0945*****,1)
– Executing [0945*****@from-trunk:1] Set(“SIP/0945*****-08ecf9c0”, “__FROM_DID=0945*****”) in new stack
– Executing [0945*****@from-trunk:2] Gosub(“SIP/0945*****-08ecf9c0”, “app-blacklist-check|s|1”) in new stack
– Executing [[email protected]:1] LookupBlacklist(“SIP/0945*****-08ecf9c0”, “”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/0945*****-08ecf9c0”, “0?blacklisted”) in new stack
– Executing [[email protected]:3] Return(“SIP/0945*****-08ecf9c0”, “”) in new stack
– Executing [0945*****@from-trunk:3] GotoIf(“SIP/0945*****-08ecf9c0”, “1 ?cidok”) in new stack
– Goto (from-trunk,0945*****,5)
– Executing [0945*****@from-trunk:5] NoOp(“SIP/0945*****-08ecf9c0”, "CallerID is “Mobile” ") in new stack
– Executing [0945*****@from-trunk:6] Set(“SIP/0945*****-08ecf9c0”, “__CALLINGPRES_SV=allowed_not_screened”) in new stack
– Executing [0945*****@from-trunk:7] SetCallerPres(“SIP/0945*****-08ecf9c0”, “allowed_not_screened”) in new stack
– Executing [0945*****@from-trunk:8] Goto(“SIP/0945*****-08ecf9c0”, “from-did-direct|400|1”) in new stack
– Goto (from-did-direct,400,1)
– Executing [[email protected]:1] GotoIf(“SIP/0945*****-08ecf9c0”, “0?ext-local|400|1”) in new stack
– Executing [[email protected]:2] Macro(“SIP/0945*****-08ecf9c0”, “user-callerid|”) in new stack
– Executing [[email protected]:1] Set(“SIP/0945*****-08ecf9c0”, “AMPUSER=Mobile”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/0945*****-08ecf9c0”, “0?report”) in new stack
– Executing [[email protected]:3] ExecIf(“SIP/0945*****-08ecf9c0”, “1|Set|REALCALLERIDNUM=Mobile”) in new stack

Now, you’ll have quite a bit in there, so just post a page or two so we can see the call handshaking.
It’s a good idea to remove any info that is best kept to yourself, use the Find & Replace function in Notetab Lite to make things easier.