Inbound calls to IVR that allow direct dial no longer work, to queues, or extensions


(Jon Kelly) #1

freepbx 13.0.197.26 / asterisk 13.7.1, after updates about 3 weeks ago, direct dial from within IVR, no longer works. Callers can get in and reach any ext, or queue, or group, if in the IVR menu, but if they direct dial, no longer works.

We use a number of queues, 180, 270, 299, , which are listed in IVR, if the IVR has a selection for the queue, it works, but if we direct dial, it not longer work, believe the IVR see’s the direct dial as invalid. Prior to update, for last 2, 3 years worked fine. Also can no longer direct dial extensions either.
But inbound, which are automatically routed to same queues, or extensions, work fine.


#2

Try setting Force Strict Dial Timeout to No - Legacy.

If that doesn’t help (or you already have that setting), paste the Asterisk log of a failing call at pastebin.freepbx.org and post the link here.


(Jon Kelly) #3

Thank you for reply, I looked in the IVR, there is no option for Force Strict Dial Timeout, in that menu. I did submit logs to pastebin, from keltekfreepbx, https://pastebin.freepbx.org/view/0960fa36 - This is after I allowed for returning to IVR after a invalid entry, so it takes my entry, then simply returns me to the IVR, so I enter 299, which is the direct dial to the queue, or to an extension, but I simply loop thru.

Up until about 2 1/2 or 3 weeks ago, after updates we found this issue. Prior, no issues.

The funny thing is, I can create a 299 entry in the IVR, that directs to queue 299, works fine. But that doesn’t help with dialing other extensions, which also don’t work.


(Jared Busch) #4

You do not have this? It has always been there, maybe named slightly different. You want it to be “No - Legacy” for your desired behavior.

I do not have any system old enough not to have the new wording, but if you do not have “No - Legacy”, then you want it to be simply “No”


(Jon Kelly) #5

No Sir ,

But I do remember the setting, but even if I create new IVR, I’ve got Enable Direct Dial, then below that, Timeout setting. All my binary choices are things like “Append announcement on invalid”, or “return on invalid”, but no I no longer have “Force Strict Dial Timeout”.


(Jon Kelly) #6

Any thought’s gents?
Anyone review that log?


#7

What version of IVR does Module Admin show you’re running? What upgrade, if any, is available?


(Jon Kelly) #8

thank you for your time and direction,

current ivr ver13.0.27.21, yes, there is an update, to 13.0.27.22.

And the last update did effect my module Admin, related to updates, but I can do them on command line, which is comfortable for me. As a matter of fact, there are quite a few updates, considering it was just upgraded a few weeks ago, so I"ll get a backup and get it done.

Thank you, I probably can’t do this till this weekend. (Image copy of vm.)


(Dave Burgess) #9

This just rung a bell…

Don’t we (FreePBX) prevent direct dialing anything but an extension from an IVR. Seems to me this changed to stop an exploit in the call forwarding code. I may be completely out in left field on that, I thought that we discussed this at length last Spring.


(Jon Kelly) #10

OK, so I couldn’t use the gui interface for updating modules, so I simply use fwconsole and amportal, to repair the gui in module admin, then upgrade my framework, core, ringgroups, queues, and asterisk-cli. Which repaired my gui for updates to modules. But by then, the upgrades I had performed, repaired the direct dial issue.

But, didn’t give me that feature, or check box for “Force Strict Dial Timeout”, but it did give me back my functionality, so thank you.


(system) closed #11

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.