Inbound calls to extensions - connection delay

On our Freepbx FreePBX 13.0.151 installation, we experience a random delay on incoming calls sent to extensions via ring groups or queues.

Sometimes there is no delay and sometimes delay is up to 5 seconds. We have tried to upgrade server power with no luck.

Any Idea how trace this and find out how to solve this is.
Since it is random if there is a delay or not, I dont expect this to be solved from any GUI setting?

But it would be great with some input on how to solve this…

If you are having 5 second delays, randomly, this is a DNS problem.

Seriously. You have a DNS server configured that is not responding. Go fix it.


Under the heading of “duh” - upgraded from 13 to 14, hand roll distro install, manually duplicated my 13 config, commercial modules work perfectly, random failures to connect, phones ring but won’t answer, etc etc etc. Forgot to populate the DNS field and turn on DDNS. I add a little (instead of the internal network default), add some and some and instantly WEEKS of confoundment fixed. Duh, duh, duh - and did I mention - duh! Good on ya Rob. Ta.