Inbound calls going straight to voicemail

Hello all,

I have Asterisk 1.6.0.26-FONCORE-r78. I am having problems receiving calls. All the calls go straight to Voicemail.

I went into the asterisk cli in the trixbox as root and tried to see whats going on and apparently after entering the command ‘sip show peers’ it shows that all of my 5 extensions are offline with a status of “unknown”.

This problem started happening when a network engineer installed a sonic wall tz215 on our network. I went into the sonic wall and under Voip settings, I tried enabling constant NAT and enable SIP transformations and reloaded asterisk but nothing changed. I also tried . The pbx server i have is behind the network so I’m not sure if NAT’ing is the issue.

I enabled ‘sip set debug on’ and at various times, it returns with the error:

Really destroying SIP dialog ‘[email protected]’ Method: REGISTER

I would just like to figure out a way to get the sip peers back online. I tried to view the debug lists by doing a 'console dial ‘extension_number’" but I don’t think it worked as it returned some GOTO and IF statements other than errors.

Any help here will suffice or a way to solve the problem further.

Thanks in advance!

Tell the network engineer to configure the firewall correctly. Did he replace an existing firewall?

We had everything going out through our Netgear before which had some basic firewall settings. I think with the install of the Sonic Wall a lot of things were changed. Does it sound like a firewall issue? I will contact him. Thanks.

If it was working before the changes I would say that is the problem.

Did you “network engineer” look at the Netgear config and replicate that config on the Sonic wall? What ports are forwarded?

Turn off the SIP ALG, they usually don’t work well.

alan_mousty
I turned off the sonic firewall settings to allow any connections and I am still getting the same issue. I am now thinking that it is not a firewall issue. I also tried turning off all sip settings prior to allowing all ports on the SonicWall but no luck. I really am stuck. I tried again with the sip debug on and its still giving me the error:

Really destroying SIP dialog ‘[email protected]’ Method: REGISTER

If it helps further alan_mousty please take a look at my sip.conf

Continuation of notes:

nsixty sip.conf

vmexten=*97
disallow=all
allow=ulaw
allow=alaw
allow=h263
allow=h264
videosupport=yes
context=from-sip-external
callerid=Unknown
notifyringing=yes
notifyhold=yes
limitonpeers=yes
tos_sip=cs3
tos_audio=ef
tos_video=af41
alwaysauthreject=yes

register=126478:n__@houston.voip.ms:5060

[601]
deny=0.0.0.0/0.0.0.0
type=friend
secret=t
qualify=yes
port=5060
pickupgroup=
permit=0.0.0.0/0.0.0.0
nat=yes
[email protected]
host=dynamic
dtmfmode=rfc2833
dial=SIP/601
context=from-internal
canreinvite=no
callgroup=
callerid=device <601>
accountcode=
call-limit=50

[602]
deny=0.0.0.0/0.0.0.0
type=friend
secret=y
qualify=yes
port=5060
pickupgroup=
permit=0.0.0.0/0.0.0.0
nat=yes
[email protected]
host=dynamic
dtmfmode=rfc2833
dial=SIP/602
context=from-internal
canreinvite=no
callgroup=
callerid=device <602>
accountcode=
call-limit=50

[603]
deny=0.0.0.0/0.0.0.0
type=friend
secret=FUn0
qualify=yes
port=5060
pickupgroup=
permit=0.0.0.0/0.0.0.0
nat=yes
[email protected]
host=dynamic
dtmfmode=rfc2833
dial=SIP/603
context=from-internal
canreinvite=no

Thanks a lot for your help! I appreciate any time you spend on this.