Inbound calls don't work after update from 2.4 to 2.5.0.1

Hello,

Before to do the update the inbound calls was working. After the update I get a busy signal. Is any bug in this new ver?

I have a sip account. I have checked only configuring the xlite and is working inbound
My server has 192.168.0.100 internal ip, and is behind a router (TrendNET) and I point DMZ to the freepbx server.
The outbound calls working.

Thanks in advance
Silviu

— (9 headers 0 lines) —
Scheduling destruction of SIP dialog ‘[email protected]’ in 32000 ms (Method: REGISTER)
elastix*CLI>
<— SIP read from 79.112.120.40:61511 —>

<------------->
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Manager ‘admin’ logged on from 127.0.0.1
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Manager ‘admin’ logged on from 127.0.0.1
== Manager ‘admin’ logged off from 127.0.0.1
== Manager ‘admin’ logged off from 127.0.0.1
Reliably Transmitting (NAT) to 79.112.120.40:56638:
OPTIONS sip:[email protected]:56638;rinstance=c0f20b08ec58727e SIP/2.0
Via: SIP/2.0/UDP 86.124.52.36:5060;branch=z9hG4bK5c9cdf80;rport
From: “Unknown” sip:[email protected];tag=as72575ce6
To: sip:[email protected]:56638;rinstance=c0f20b08ec58727e
Contact: sip:[email protected]
Call-ID: [email protected]
CSeq: 102 OPTIONS
User-Agent: Asterisk PBX
Max-Forwards: 70
Date: Sun, 19 Oct 2008 10:37:04 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces
Content-Length: 0

Retransmitting #1 (NAT) to 79.112.120.40:56638:
OPTIONS sip:[email protected]:56638;rinstance=c0f20b08ec58727e SIP/2.0
Via: SIP/2.0/UDP 86.124.52.36:5060;branch=z9hG4bK5c9cdf80;rport
From: “Unknown” sip:[email protected];tag=as72575ce6
To: sip:[email protected]:56638;rinstance=c0f20b08ec58727e
Contact: sip:[email protected]
Call-ID: [email protected]
CSeq: 102 OPTIONS
User-Agent: Asterisk PBX
Max-Forwards: 70
Date: Sun, 19 Oct 2008 10:37:04 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces
Content-Length: 0

Besides that its suicidal to put your server in dmz if you dont know what your doing, the log that you provided doesnt show much. Please turn off sip debugging and set verbose to 5

Hello,

I know I should not use DMZ, but taking into account is a test server is no problem, I wanted to avoid port fwd problms.

thanks

So after cmd set verbose 5 get this:

host*CLI> core set verbose 5
Verbosity was 3 and is now 5
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate

any ideas?

About what?

Hi
did you see my post?

Which one? You mentioned two individual problems.You also didn’t follow the instructions that you were given. What is it that you want help with?

It 's about this post
"inbound calls don’t work after update from 2.4 to 2.5.0.1 "
In this post I did all …I think, was only 2 cmds

I can confirm that. I can’t get any kind of inbound call routing (to any destination: callback, anouncement, voicemail) to work anymore since the upgrade.

The callerid is succesfully detected but the callflow does not care about the specified call routing…

Don’t know what’s wrong today, i keep posting this issue in the wrong thread…
Sorry guys, please skip this one here :wink:

Keep mine is still unsolved :slight_smile:
thanks

I turned off sip debugging and set verbose to 5 as you can see after that post:

So after cmd set verbose 5 get this:

host*CLI> core set verbose 5
Verbosity was 3 and is now 5

thanks

judging from your log… hmm, you didnt re post any log like you were instructed. So I guess there is no problem after all.

Check XLite and Reset you Secret …

Then check sip_nat.conf

== Connect attempt from '192.168.0.100' unable to authenticate

Shows that XLite is not connecting –

No sign of a call coming in SIP or Zap in what you posted !!

trixbox1*CLI> core set verbose 5
Verbosity was 20 and is now 5
trixbox1*CLI> sip set debug off
SIP Debugging Disabled
   -- Executing [[email protected]:1] Set("SIP/5060-08b68040", "__FROM_DID=7701231234") in new stack
    -- Executing [[email protected]:2] Gosub("SIP/5060-08b68040", "cidlookup|cidlookup_1|1") in new stack
    -- Executing [[email protected]:1] Set("SIP/5060-08b68040", "CALLERID(name)=Atlanta, GA Cell Phone") in new stack
   ---  Excreta 

in sip_nat.conf is no line

The xlite is connected and I can do outbound calls

How I reset the secret?

Yes is no sign of call comming on SIP that’ why I open this ticket.
I had setup an IVR so when I called the audiofile was playing. So after update I get only bip signal and than like a busy tone
You can try call 0040332560285.
Also I can give you my server details if you want to take a look.

Now I have xlite connected but same message with the cmd asterisk -r

Thanks

== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
== Connect attempt from ‘192.168.0.100’ unable to authenticate