Inbound caller ID includes @IP address

Hi,

I’m running the following FreePBX Distro:
Your Linux Distribution: (Redhat Sangoma Linux release 7.4.1712 (Core) )
Your FreePBX version: (14.0.3.1)

All the inbound caller IDs are being displayed on my Softphones as [email protected] for example [email protected]:1234, rather than just the incoming calling number from the PSTN.

Any help would be appreciated.

Thanks

Which “my Softphones”?

What they are displaying is absolutely correct - the call is being sent from that server. The problem is likely in the way your phone is configured.

That’s a function of how the softphone works and displays CID. I’ve noticed that X-Lite shows the server IP too.

Hi Dave (@cynjut)

I use X-Lite 3 and also Phoner Lite, and they both perform the same way. Interestingly, I use the same softphone configuration (except for the server address/password) with another FreePBX system ( FreePBX 13.0.194.10 ) that system only passes the caller ID to the phone.

With X-Lite, you can have an address book that will look up the Caller ID and display the person’s name (if in the book). To get X-Lite to display the name on the softphone with the the FreePBX 14 system, X-lite needs to include the @ IP address to match correctly. With the @'s in the number entry, the address book entry cannot be used to dial out.:confused.

I’m confused.

I can’t do the research right now, but aren’t both of those tied to a commercial PBX system, as in they are intended for a specific system, rather than a generic PBX?

There are other headers that can be sent with the originating traffic when the call is established that have the CID information in them. Perhaps the applications are set up to display what they are displaying, but need to be configured to use one of those other headers, or perhaps the phone app is designed to use one of the alternate CID packets instead?

FreePBX 14 can use several different versions of Asterisk, but it seems to me that this could be a problem with the way that Asterisk is configured (by FreePBX) and you just need to adjust some of the settings to get it to work. I can’t be more specific, though, since I don’t use either of those and my systems aren’t upgraded to 14 yet.

Thanks David, I suspect you are correct. I’ll have to research Asterisk to find a solution.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.