Inbound call to IVR drops after 21 seconds?

Does anyone know why?

ThePBX*CLI>
– Executing [[email protected]:1] Set(“SIP/202.101.202.101-b763ce60”, “__FROM_DID=310-456-7890”) in new stack
– Executing [[email protected]:2] ExecIf(“SIP/202.101.202.101-b763ce60”, “1 |Set|CALLERID(name)=310-456-0987”) in new stack
– Executing [[email protected]:3] Ringing(“SIP/202.101.202.101-b763ce60”, “”) in new stack
– Executing [[email protected]:4] Set(“SIP/202.101.202.101-b763ce60”, “FAX_RX=disabled”) in new stack
– Executing [[email protected]:5] Set(“SIP/202.101.202.101-b763ce60”, "[email protected]") in new stack
– Executing [[email protected]:6] Set(“SIP/202.101.202.101-b763ce60”, “__CALLINGPRES_SV=allowed_not_screened”) in new stack
– Executing [[email protected]:7] SetCallerPres(“SIP/202.101.202.101-b763ce60”, “allowed_not_screened”) in new stack
– Executing [[email protected]:8] Goto(“SIP/202.101.202.101-b763ce60”, “ivr-2|s|1”) in new stack
– Goto (ivr-2,s,1)
– Executing [[email protected]:1] Set(“SIP/202.101.202.101-b763ce60”, “MSG=custom/AA-Msg”) in new stack
– Executing [[email protected]:2] Set(“SIP/202.101.202.101-b763ce60”, “LOOPCOUNT=0”) in new stack
– Executing [[email protected]:3] Set(“SIP/202.101.202.101-b763ce60”, “__DIR-CONTEXT=default”) in new stack
– Executing [[email protected]:4] Set(“SIP/202.101.202.101-b763ce60”, “_IVR_CONTEXT_ivr-2=”) in new stack
– Executing [[email protected]:5] Set(“SIP/202.101.202.101-b763ce60”, “_IVR_CONTEXT=ivr-2”) in new stack
– Executing [[email protected]:6] GotoIf(“SIP/202.101.202.101-b763ce60”, “0?begin”) in new stack
– Executing [[email protected]:7] Answer(“SIP/202.101.202.101-b763ce60”, “”) in new stack
– Executing [[email protected]:8] Wait(“SIP/202.101.202.101-b763ce60”, “1”) in new stack
– Executing [[email protected]:9] Set(“SIP/202.101.202.101-b763ce60”, “TIMEOUT(digit)=3”) in new stack
– Digit timeout set to 3
– Executing [[email protected]:10] Set(“SIP/202.101.202.101-b763ce60”, “TIMEOUT(response)=300”) in new stack
– Response timeout set to 300
– Executing [[email protected]:11] Set(“SIP/202.101.202.101-b763ce60”, “__IVR_RETVM=RETURN”) in new stack
– Executing [[email protected]:12] ExecIf(“SIP/202.101.202.101-b763ce60”, “1|Background|custom/AA-Msg”) in new stack
– <SIP/202.101.202.101-b763ce60> Playing ‘custom/AA-Msg’ (language ‘en’)

ThePBXCLI>
ThePBX
CLI>
ThePBXCLI> 20 seconds goes by,
ThePBX
CLI>
ThePBXCLI>
ThePBX
CLI>
== Spawn extension (ivr-2, s, 12) exited non-zero on ‘SIP/202.101.202.101-b763ce60’
– Executing [[email protected]:1] Hangup(“SIP/202.101.202.101-b763ce60”, “”) in new stack
== Spawn extension (ivr-2, h, 1) exited non-zero on ‘SIP/202.101.202.101-b763ce60’

The problem was that I had moved the box
to a different IP address.

Needed to change the following setting in:

sip_general_custom.conf

externip=The.New.Actual.IP