Inbound Call Recordings

We are using freePBX to manage several inbound routes. these go to queues and thence to extensions to be handled. on version 2.9 inbound calls via a queue were recorded based on the extension settings. call recording on the queue is not desirable and was not enabled on the queue due to the need to record on a per extension basis and not on all queue traffic

We have upgraded a couple of boxes to FreePBX 2.10 and the call recording appears to have been changed.

when a call is inbound via a queue and call recording is set to off on the queue the call does not get recorded despite being set to record if a call comes in direct to the extension and inbound call recording being set on the extension.

Therefore inbound calls via a queue are appearing to ignore the extension recording settings on the latest 2.10 version

Is there any way to restore the call recording to the extension via the queue without the queue being recorded as per ver 2.9?

Same problem here. Can some one assist us please ?



We found a solution to this problem.

It’s caused by a bug (or may a feature?) in the new sub routine which deals with recoridngs - sub-record-check.

If the queue is set to not record, then REC_STATUS=INITIALIZED is set and never cleared, which is then carried through to the extension check, and because this value is set, the extenension check is skipped, thus meaning no recordings if queue is set to not record, and extension is set to record.

We’ve got a fix, which can be applied in extensions_override_freepbx.conf. Copy the whole [sub-record-check] sub into this file, and adjust the queue part as such (two lines in middle added):

exten => q,1,GosubIf($["${REC_POLICY_MODE}"=“always”]?recq,1(${EXTEN},${ARG2},${FROMEXTEN}))
; WL 02/04/2012 Added so that calls from queues which are not set to record, to extensions which are, will record correctly.
exten => q,n,Set(__REC_STATUS=)
exten => q,n,Set(__REC_POLICY_MODE=)
exten => q,n,Return()

Hope this helps!

Also - If there is somewhere else I should post about this bug, then just let me know and I will!



This is all by design. If a queue recording option supersedes the extension. So if the queue is set to no than the extension does not have permission to record that call.

You can open a feature request to add a 3rd option to the queue recording of “Dont Care” just like we have in extensions that if set would allow any extension to record the call if the extension was set.

I did wonder if if was a bug, or if it was by design. It was definitely a change from 2.9 behaviour, but luckily we caught it before we’d lost too many important recordings.

A “don’t care” on the queue would definitely solve this issue, as that’s the behaviour a lot of people look for. Not having recording enabled on the queue is more an indication that you’ll decide later on, rather than an indication that you 100% don’t want to record any calls from this queue.

Take for example a company has a general incoming number, which is then answered by reception and transferred to the relevant party, the decision to record the call or not, is often based on the nature of the call, and therefore the end party/extension.

I have the same problem. We need a way to record the calls from a specific extension. How can we enable that option?

Thanks for your help

For " . . from a specific extension . . " did you enable “Record Outgoing always” for that extension?

The record always on that extension is enabled. The problem is when an inbound call is coming from a ring group that is set to not record calls, then it supersedes the settings on the extension and there is no recording for the call. I will need to monitor a specific extension always, no matter if the call comes directly or from a queue or ring group. However since we upgrade to 2.10 and then 2.11 we lost that feature.

You said explicitly:-

We need a way to record the calls from a specific extension

from means from, and indicates a an outgoing call, to means to . . . .