Inbound call problem

having an issue with inbound calls, when I dial the number I get an all circuits are busy message.

Checking the logs shows my pbx sending a 503 error out.

Pcap shows inbound call hit the pbx and respond with an invite to a destination of s

Honestly this is driving me crazy as I cant find where this is coming from.

Can anyone help?

Log file here shows call trying to go to s

[2013-05-25 23:32:36] VERBOSE[2412][C-00000017] netsock2.c: == Using SIP RTP TOS bits 184 [2013-05-25 23:32:36] VERBOSE[2412][C-00000017] netsock2.c: == Using SIP RTP CoS mark 5[2013-05-25 23:32:36] VERBOSE[2412][C-00000017] app_dial.c: -- Called SIP/VItrunk1/s [2013-05-25 23:32:37] VERBOSE[1769][C-00000017] chan_sip.c: -- Got SIP response 503 "No Circuit Available" back from 64.136.174.30:5060 [2013-05-25 23:32:37] VERBOSE[2412][C-00000017] app_dial.c: -- SIP/VItrunk1-00000031 is circuit-busy [2013-05-25 23:32:37] VERBOSE[2412][C-00000017] app_dial.c: == Everyone is busy/congested at this time (1:0/1/0) [2013-05-25 23:32:37] VERBOSE[2412][C-00000017] pbx.c: -- Executing [[email protected]:10] Set("SIP/VItrunk1-00000030", "CALLERID(number)=160244*****") in new stack [2013-05-25 23:32:37] VERBOSE[2412][C-00000017] pbx.c: -- Executing [[email protected]:11] Set("SIP/VItrunk1-00000030", "CALLERID(name)=160244*****") in new stack [2013-05-25 23:32:37] VERBOSE[2412][C-00000017] pbx.c: -- Executing [[email protected]:12] Hangup("SIP/VItrunk1-00000030", "") in new stack [2013-05-25 23:32:37] VERBOSE[2412][C-00000017] pbx.c: == Spawn extension (ext-trunk, tdial, 12) exited non-zero on ''''SIP/VItrunk1-00000030''''