Inbound call behaves as if it is not touch-tone call

I am trying to setup an inbound route from a SIP provider. I have tried two things:

a) The inbound route finishes into an IVR where the user has to press buttons. After succesfully dialing in, while I can hear the geeting message, unfortunately, no matter what I press, asterisk does not understand/convert into digits the signal and as a result the IVR timeouts

b) The inbound route finishes into an extension mailbox. I am able to dial in, connect, leave a message, however Asterisk does not understand that I am pressing # and as a result never ends up the call.

In both cases the asterisk log does not record anything pressed, as if there was complete silence.

These leave me to believe that somehow I am not setting up the inbound route as a touch tone route (if that is even possible).

Here are my inbound settings for the SIP trunk:

disallow=all
allow=ulaw&alaw&gsm&g729
canredirect=no
context=from-trunk
fromdomain=voip.freephoneline.ca
fromuser=MY_NUMBER
secret=MY_PASSWORD
type=friend
username=MY_NUMBER
nat=yes

This is the traceback:

== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
== Using SIP VRTP TOS bits 136
== Using SIP VRTP CoS mark 6
– Executing [[email protected]:1] Set(“SIP/FPLTrunk-00000010”, “__FROM_DID=MY_NUMBER”) in new stack
– Executing [[email protected]:2] Gosub(“SIP/FPLTrunk-00000010”, “app-blacklist-check,s,1”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/FPLTrunk-00000010”, “0?blacklisted”) in new stack
– Executing [[email protected]:2] Return(“SIP/FPLTrunk-00000010”, “”) in new stack
– Executing [[email protected]:3] ExecIf(“SIP/FPLTrunk-00000010”, “0 ?Set(CALLERID(name)=anonymous)”) in new stack
– Executing [[email protected]:4] Set(“SIP/FPLTrunk-00000010”, “__CALLINGPRES_SV=allowed_not_screened”) in new stack
– Executing [[email protected]:5] Set(“SIP/FPLTrunk-00000010”, “CALLERPRES()=allowed_not_screened”) in new stack
– Executing [[email protected]:6] Set(“SIP/FPLTrunk-00000010”, “_RGPREFIX=FPL:”) in new stack
– Executing [[email protected]:7] Set(“SIP/FPLTrunk-00000010”, “CALLERID(name)=FPL:Anonymous”) in new stack
– Executing [[email protected]:8] Goto(“SIP/FPLTrunk-00000010”, “ivr-3,s,1”) in new stack
– Goto (ivr-3,s,1)
– Executing [[email protected]:1] Set(“SIP/FPLTrunk-00000010”, “MSG=custom/welcome-back”) in new stack
– Executing [[email protected]:2] Set(“SIP/FPLTrunk-00000010”, “LOOPCOUNT=0”) in new stack
– Executing [[email protected]:3] Set(“SIP/FPLTrunk-00000010”, “__DIR-CONTEXT=default”) in new stack
– Executing [[email protected]:4] Set(“SIP/FPLTrunk-00000010”, “_IVR_CONTEXT_ivr-3=”) in new stack
– Executing [[email protected]:5] Set(“SIP/FPLTrunk-00000010”, “_IVR_CONTEXT=ivr-3”) in new stack
– Executing [[email protected]:6] GotoIf(“SIP/FPLTrunk-00000010”, “0?begin”) in new stack
– Executing [[email protected]:7] Answer(“SIP/FPLTrunk-00000010”, “”) in new stack
– Executing [[email protected]:8] Wait(“SIP/FPLTrunk-00000010”, “1”) in new stack
– Executing [[email protected]:9] Set(“SIP/FPLTrunk-00000010”, “TIMEOUT(digit)=3”) in new stack
– Digit timeout set to 3
– Executing [[email protected]:10] Set(“SIP/FPLTrunk-00000010”, “TIMEOUT(response)=10”) in new stack
– Response timeout set to 10
– Executing [[email protected]:11] Set(“SIP/FPLTrunk-00000010”, “__IVR_RETVM=RETURN”) in new stack
– Executing [[email protected]:12] ExecIf(“SIP/FPLTrunk-00000010”, “1?Background(custom/welcome-back)”) in new stack
– <SIP/FPLTrunk-00000010> Playing ‘custom/welcome-back.slin’ (language ‘en’)
– Executing [[email protected]:13] WaitExten(“SIP/FPLTrunk-00000010”, “,”) in new stack
== Spawn extension (ivr-3, s, 13) exited non-zero on ‘SIP/FPLTrunk-00000010’
– Executing [[email protected]:1] Hangup(“SIP/FPLTrunk-00000010”, “”) in new stack
== Spawn extension (ivr-3, h, 1) exited non-zero on ‘SIP/FPLTrunk-00000010’

Thank you

Do you have the tone zone set to the correct country/continent? When you created your SIP extensions, did you select dtmfmode=rfc2833?

Yes. I have tried the following: rfc2833, auto, info --> none worked!!! The thing is that when dialing OUT using freephoneline, then rfc2833 does the trick.

  1. what are all the possible values for the parameter?

  2. Any idea what can I do to see to trace and see in the asterisk log what is the value for dtmfmode?

who is the provider, that is a first step in people helping since these things can be very provider dependent.

Provider is freephoneline.ca

I think there is a problem with the provider as other people are reporting the same issues … I thought I am not configuring the line properly …

I have solve my problem with: dtmfmode=auto
IVR work and i can call entreprise with IVR!
Peer detail:
username=1xxxxxxxx
type=friend
secret=xxxxxxxxxx
qualify=no
insecure=very
host=voip.freephoneline.ca
fromdomain=voip.freephoneline.ca
dtmfmode=auto
disallow=all
context=from-trunk
canreinvite=yes
allow=g729&ulaw

USER Details:
same without context=from-trunk

Do you have new about this subject ?
I have freephoneline and I not able to dial extension number or IVR from inbound. Same problem when I call from outbound to someone with IVR.
Anwser?

Nothing has changed with my provider but when a call comes in the IVR will not accept touch tones from them, if I call from a local ext then it works?
I have several providers and none work; what can it be?

Thanks!