Inband DTMF detection not working

Installed FreePBX 13 (10.13.66-19).
Telco provider uses G.711 a-law and inband DTMF.
Log File Settings have DTMF logging enabled (ON) for both full and console.
chan_sip is used for SIP Traffic.
Ring Signal is enabled on Inbound route.
Simple IVR has been used as a test endpoind.

For unknown reason there is no trace of DTMF keystrokes logged in system logs (so IVR does not recognize DTMF).

I’ve tried many suggestions found over the last few years on many forums (rfc2833compensate, relaxdtmf), but nothing helped.
Tried other DTMF options (RFC2833, INFO, SHORTINFO, AUTO) but without success.
Tried to test is DTMF really “inbound” using test conference room, but this works perfectly (DTMF signal can be heard from all sides).
I am not able to change operator, and inband is only available option, so I’m stuck with this.

Please advise further steps, what else to look for, how to solve this?
This seems as some system-level problem, or a serious misconfiguration?