In-Call Call Recording (How to use?)

I installed from PBX in a Flash 1.3, using CentOS release 5.2 (Final) 32-bit, Kernel 2.6.18-92.1.6.el5 (SMP) FreePBX with Asterisk, Zaptel 1.4.11, libpri 1.4.7, addons 1.4.7

I thought i mentioned I’d tried X-lite but scrolling up aparently I forgot. The phyical phones I’m using are Linksys IP Phone SPA922, but the same problem exists with X-lite.

edit, that seems to be working for me too with the timeout set, thanks

featuredigittimeout = 1500
did it for me, but it only works on X-Lite and not on my Grandstream GXP2000.

How could I get it working on the Grandstream?

I have not personally used a Grandstream IP phone, so I cannot directly assist you. My suggestion is to investigate the Grandstream Dial Plan. Some phones have a specific configuration for dial plans and might be blocking *1 as an invalid number.

At least we know the server is working properly in recording on demand.

Solved the problem with the grandstream. Had to set send DTMF to “via RTP (RFC2833)”.

Just another problem:
The recording is stored as two files. 1 for outgoing and 1 for incoming. Is there any way to have out and in in one file?

No it works well for outgoing calls, but if I receive a call, it doesn’t record, when I press *1.

Any hints on that?

Just double check you have completed all steps outlined above. I can’t think of anything else.

Followed the thread, recording is fine with GXP2000.
Only level is low…
On voicemail messages, I added 12db gain on “General settings”.
I will try to find where to boost the gain in .conf files
Thank you all, i’ve been looking for recording for a while !!!

I have found the following to work on Pbxiaf, as well as those others:

Asterisk Dial commands options = tTwWr
Asterisk Output Dial commands options = tTwW

In features_general_custom.conf (place the following and reload)


If you’ve done it right when you hit *1 you will here a beep.

I had the same problem getting on-demand call recording working. I resolved the issue by following the suggestions in this thread.

  1. On the General Settings page, add “wW” to “Asterisk Dial command options” making its value “trwW”

  2. On the phone, change the dial plan to accommodate *1 with this:



For me, these were the only two steps needed:

  • Changing the Asterisk Dial command options to add “w” to the default “tr” (so the whole string is “trw”) and the Asterisk Outbound Dial command options to add “W” to the default empty string (so the whole string is “W”) (with this configuration, only the Asterisk side on internal<->external calls can issue the record command)
  • I had to dial *1 quickly – if there is too much of a pause between the * and the 1, the other side hears the two DTMF tones and no recording starts or stops

I didn’t need to make any dial plan changes or other changes.


the call recording option in freepbx is not working,i tried with both on demand and always option,also checked the call recording toggle command *1,and have also given the asterisk dial command options and asterisk outbound dial command options trWw and Ww…still the recordings not working,but my voice mail is working ,im using xlite softphone,can anyone find the reason,should i add the commands through asterisk CLI

if anyone knows the solution please do help

A very nice trouble shooting steps by scottcupit as i have faced the same issue which were resolved after following scottcupit steps, thank you very much and keep up the good work.

freepbx set to:
Asterisk Dial commands options = tTwWr
Asterisk Output Dial commands options = tTwW
grandstream gxp2000: set to DTMF to via RTP (RFC2833)
Added the following line to /etc/asterisk/features_general_custom.conf
featuredigittimeout = 1500

when I press *1, the call is disconnected