Improper sound language and file not found

I have configure the default language to be in spanish.
i made an announcement with a prerecorded sound “digits/0” in system recordings.
when i heard the sound in system recordings [freepbx] it sounds in spanish. the voice says “CERO”
then i made a misc application to hear directly the announcemt from extension 300.
when i make a call to 300 I hear an english voice saying “ZERO” although in asterisk-cli is shown that the spanish audio is playing:
Playing ‘digits/0.slin’ (language ‘es’)

when I used a custom recording, recorded from an extension using system recordings and then exporting in every format (ulaw, wav, alaw, etc). saving it in spanish or in english i get the following error:
File custom/unooo does not exist in any format
Unable to open custom/unooo (format (ulaw)): No such file or directory

I checked the directory /var/lib/asterisk/sounds/es/custom/unoo.ulaw and it does exists
belongs to asterisk:asterisk and has -rwxrwxrwx permissions.
I copy the file to the english directory but still get the same error

checked the file formats available with “core show file formats” in angular cli
and got the following

Format Name Extensions

slin mp3 mp3
h263 h263 h263
h264 h264 h264
g723 g723sf g723|g723sf
siren14 siren14 siren14
ilbc iLBC ilbc
adpcm vox vox
gsm gsm gsm
g719 g719 g719
vp8 VP8 vp8
slin16 wav16 wav16
slin wav wav
g726 g726-16 g726-16
g726 g726-24 g726-24
g726 g726-32 g726-32
g726 g726-40 g726-40
siren7 siren7 siren7
slin192 sln192 sln192
slin96 sln96 sln96
slin48 sln48 sln48
slin44 sln44 sln44
slin32 sln32 sln32
slin24 sln24 sln24
slin16 sln16 sln16
slin12 sln12 sln12
slin sln sln|raw
g729 g729 g729
slin ogg_vorbis ogg
gsm wav49 WAV|wav49
g722 g722 g722
ulaw au au
alaw alaw alaw|al|alw
ulaw pcm pcm|ulaw|ul|mu|ulw
33 file formats registered.

file unooo.wav
unooo.wav: RIFF (little-endian) data, WAVE audio, Microsoft PCM, 16 bit, mono 8000 Hz

file unooo.ulaw
unooo.ulaw: data

plzzz help

asterisk 13.18.3
ubuntu 18.04.1 LTS

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.