Impossible to change SIP Signal port 5060

I have FreePBX (4.211.64-9) and CSipSimple nightly build 1.01.00 r2352 and it works OK with port 5060.
When I change 5060 to another port xxxx in FreePBX - according to the documentation:

  1. Asterisk SIP Settings bindport=xxxx
  2. Extensions / Device Options port=xxxx
  3. Reboot

it shows that port xxxx has been accepted:
lsof -i :xxxx
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
asterisk 2068 asterisk 17u IPv4 11835 0t0 UDP *:xxxx
and lsof -i :5060 gives nothing

In the firewall I have changed forwarding port (UDP) 5060 -> xxxx.
The only change I made in CSipSimple was in Settings/Network/UDP Port 0 -> xxxx

If I go backwards and change port xxxx -> 5060 it works … hmmm
So where is the problem ?
Is the port 5060 hardwired into FreePBX and CSipSimple ?

No. it’s not hardwired.

So what is the solution ?

You can’t set “Extensions / Device Options port=” without first changing host from dynamic to your endpoint’s IP address.

Thanks - now it works.
When changing SIP Signal port the documentation says that ‘Asterisk SIP Settings bindport’ should be changed but nothing about ‘Extensions / Device Options port’.
The documentation should be updated.