Import FreePBX distro on GCE problem

-No, my VM still running during the process.
-I have reached cloudendure support and still waiting for them to respond to my attachment in the mail.
-And I could use chat support on GCP to help me out with my problem on virtualbox ? I also attach the image of the chat support category, is it correct ?

p/s: also my gcp project is under 1 year, could I still use the chat support function for it ?

I usually start by calling the toll free number. They will generate the ticker and I usually get an email within 24 business hours. I solved two issues like this.

When you solve it, please let us know what was the issue and how to solve it.


thx, i’ll do that

Also do you have any idea why my call on freepbx cloud drop after 6s ( extension to extension) (I managed to use the instruction from Almost PBX to install freepbx + centos 7 on gcp).
I have set the public ip static = external ip on gcp

Does a call to *43 (echo test) drop? Can you hear the announcement? Does the echo test work? If any of this fails, use it as a test call to log. Otherwise, use a call between extensions and report whether callee can hear caller and whether caller can hear callee.

At the Asterisk command prompt, type
pjsip set logger on
(or sip set debug on if you’re using chan_sip), make the failing call, paste the relevant portion of the Asterisk log at and post the link here.

yes, the *43 also fail too, and both caller and callee can’t hear each other, also here is the link to my post about the problem with log include Call drop by using extension number drop after 6 second on hosted PBX ( the external ip in the post has been changed for security)

People in this community may able to help with this “Call (extension to extension) drops after 6s”

Are extensions up all the time? check “FreePBX Statistics” in Dashboard

I had issues in the past not hearing the other side on the call that was solved by playing with Advanced setting in the Extension.

DTMF Signaling (I have it set to Auto)
NAT Mode (I have it set to Yes)

Other places to look at is firewall rules local, FreePBX and GCP firewall.

I have set rule for the ports use for communication but still don’t know why, maybe I’ll try the setting in advanced

I considered that log to be junk and didn’t read it. For starters, please don’t post screenshots with text. In the FreePBX GUI, go to Reports->Asterisk Logfiles. Copy the relevant section to an editor, modify any IP addresses, phone numbers, etc. that are personal, paste the result at and post the link here.

Next, you posted more than 12 minutes worth. If your call takes 2 seconds to answer and drops 6 seconds later, then 10 seconds of log is all you need post, but of course it should be the correct 10 seconds.

thank you I’ll do that

Here is the link to my log:

Settings -> Asterisk SIP Settings, NAT Settings:
External Address should be your public IPv4 address. Usually clicking Detect Network Settings will set it correctly. Local Networks should be / 8.

After changing these, Submit and Apply Config, you must also restart Asterisk

Then retest – there may be more stuff wrong, in which case post another log.

If External Address and Local Networks were already correctly set, I don’t know what’s wrong; did you mess with any chan_sip settings that you think may be relevant? Also, why are you using chan_sip (you tried it after having trouble with pjsip, known incompatibility between pjsip and some device you have, etc.)?

I found out that I’ve set the wrong public IP and set it back and managed to make a call , but now only the Caller could hear the Callee . Also I set the NAT on chan_sip setting to No.
I use chan_sip since I don’t really know how to use pjsip ( I’m still new to Asterisk).
Here is the log about the situation I just said:

For both extensions, Advanced tab, NAT Mode should be Yes.
(It should also be Yes in chan_sip settings, but that’s only a default and changing it doesn’t affect already existing extensions).

Also, make sure that the UDP port range for RTP (default is 10000-20000) is in your Ingress rules in Google VPC network Firewall rules.

If no luck, post another log.

thank you, it’s work, I think setting extension NAT mode to force both causing the problem, just don’t know why.
Also should I change to using pjsip instead of chan_sip , and also the reason . Thx

Well, if it ain’t broke, maybe you shouldn’t fix it, but chan_sip is deprecated for good reason; it has some architectural faults and limitations that will never be fixed.

For example, pjsip extensions don’t have any NAT settings – it looks at what comes in and does the right thing.

However, chan_sip will be around for a long time, because the authors have worked around numerous quirks presented by various devices and trunking providers. The pjsip philosophy seems to be “if it violates the RFCs, we won’t make any effort to accommodate it”.

1 Like

Just a tip. In GCP >> VPC networks >> Firewall rules:

  • [default-allow-http], [default-allow-https], and [default-allow-ssh] will allow access from any IP. I suggest disable each one of these rules (click edit and all the way down there is an option to disable the rule). Then, create a new rule based on your need for each port that will restrict access to your trusted IPs. Add the tag to your VM instance.

It seems like that the iso I download from freepbx official website don’t have the build directory in the kernel modules so that I can’t run the agent installer

Can you test to see if you can get CentOS7 installed on the GCP from a VM using the same steps?

This may help differentiate if the issue from the iso or the process. If CentOS7 installation work, then you may want to look for an older ISO (the one from April 2019 worked for me) and upgrade after install

which setting did you choose when install freepbx distro, I chose the recomended one ( the asterisk 13)