FreePBX | Register | Issues | Wiki | Portal | Support

Implication of changing SIP Channel Driver to both

configuration
asterisk
freepbx
Tags: #<Tag:0x00007f749eecb0c0> #<Tag:0x00007f749eecaf80> #<Tag:0x00007f749eecad50>

(Pa Si) #1

My FreePBX is running on version 13.0.197 with the Asterisk version 13.18.3.
I am looking to test drive the Zulu; however, from the FreePBX web dashboard I was told “Invalid SIP Driver for Zulu”

SIP Channel Driver must be set to both or chan_pjsip in Advanced Settings. Then restart Asterisk

This is currently set to chan_sip.
Could there be any a negative effect if I change this is to both?
Is there anything I can do ahead of time to ensure phone calls will still going through fine after the change?

Thank you.


(Lorne Gaetz) #2

It should work just fine with zero disruption. I can think of 1 or 2 occasions when the bind ports mysteriously changed, but this will probably not happen. You will want to first check the bind port for chan_sip in Asterisk SIP Settings, it will probably be 5060. Then change the driver in advanced settings. Before you click apply config, browse back to Asterisk SIP settings and ensure the bind port didn’t change. After that you apply config and restart Asterisk.


(Pa Si) #3

You are right. It did changed to 5062.
What should I do now?


(Pa Si) #4

I changed the SIP Channel Driver to both and hit Submit. I came back to Asterisk SIP settings and the bind port was automatically changed to 5062.
Is there anything else could be changed automatically with the SIP Channel Driver set to both?
The Apply Config is still hanging there.

If I can the SIP Channel Driver back to chan_sip would all the change(s) be automatically reverted?

If worst comes to worst, how can I make the “Apply Config” not apply and go away?


(Lorne Gaetz) #5

Change the chan_sip bind port back to whatever it started as. You will probably have to change the pjsip bind port first.


(Pa Si) #6

Is this the “Port to Listen On” under Settings -> Asterisk SIP Settings -> Chan PJSIP Settings?
This value is showing at 5060 for me at this time.


(Pa Si) #7

I returned the SIP Channel Driver value to chan_sip only, click submit.
Go to Settings -> Asterisk SIP Settings -> Chan PJSIP Settings, changed the Port to Listen On to 5062.Click submit.
Then change the chan_sip port to 5060, then click submit.
And finally click apply.
Restarted asterisk and the system is still work.

Will need to backup the system before I can go back and test these change again.
Messing with these setting without backup plan is too dangerous!!!


(system) closed #8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.