I'm screwed!

I have set in motion the port of our isdn phone number tO my new sip pbx. As of tues/wed next week it will happen and 18 members of staff rely on it for livelihood.

However I’ve got massive issue. After about 10 mins the pbx decides to not hang up calls on termination. This is regardless of who hangs the call. According to logs calls are still active.

I’m so stressed by this

People what can I do ?

Your post does not include and information on versions or configuration of your PBX so impossible to comment on your predicament.

It seems if this is so urgent you should consider using the FreePBX support team. You will have the security of knowing the problem was fixed and your staff will have reliable communications.

Your right.
Latest free pbx
Cisco 7960gs
Connected to Cisco rv082 router with dhcp on
Routers is attached to cable modem router which is also running nat (not though choice)

Asteridk shows bye command but doesn’t work

If you can’t take the time to send a complete message “latest FreePBX” is meaningless. How was it install, what OS, SIP provider, trunk setup.

You want help you need to supply help. Properly formatted logs good also.

You should use the support option.

I appologise I wrote the post from my iphone at home, late last night worrying over what im gonna do for next week.

I am now in the office and would very much appreciate your help. I’d be very very grateful.

What specific logs would you like.

Asterisk log?
sip debug.

Yesterday I found - if I reboot the pbx all is well for about 10mins. Then calls dont hangup.
I have just arrived at the office after 10+ hours and its working again. Its random.
It sounds like a NAT issue - but i just dont have the level of skill for networking.

We have had a significant change in our setup. Our internet connection is fibre from a cable company - Virgin Media.

In order to get a static IP we had to upgrade to their new 50mb service. With this came new equipment - a SuperHub. They no longer supply cable modems, the superhub is a cable modem/router in one. You cannot put it in bridge mode. After long heated discussion - the only solution they had was to join my router to the super hub under a subnet. (they provided extra static IP’s to do this)

So instead of my router getting a local IP from the super hub - I can use one of the statics to pretend to my router that its connected to a standard cable modem.

I even asked if i could purchase my own cable modem - but they have it locked their end by mac address and will not allow other hardware.

What info can I give you - for assistance.

Thanks in advance.

I do notice this in the log when the error happens. The phone will not disconnect and says this:

Connected to Asterisk 10.12.1 currently running on localhost (pid = 1457)
Verbosity was 3 and is now 57
[2013-06-29 08:52:34] WARNING[1648]: chan_sip.c:4254 __sip_autodestruct: Autodestruct on dialog ‘[email protected]’ with owner SIP/501-00000008 in place (Method: BYE). Rescheduling destruction for 10000 ms
[2013-06-29 08:52:41] WARNING[1648]: chan_sip.c:4254 __sip_autodestruct: Autodestruct on dialog ‘[email protected]’ with owner SIP/501-00000008 in place (Method: BYE). Rescheduling destruction for 10000 ms
[2013-06-29 08:52:47] WARNING[1648]: chan_sip.c:4254 __sip_autodestruct: Autodestruct on dialog ‘[email protected]’ with owner SIP/501-00000008 in place (Method: BYE). Rescheduling destruction for 10000 ms

Well, that’s a lot different. It’s probably not so much a NAT issue as it is some type of session time out. Have you forwarded ports 5060 and 10000-20000 via this “super hub”? How configurable is it?

I just can’t imagine a carrier not offering bridge mode.

Also you say it’s fiber but then you say cable modem, talking in circles? Is it a symmetric fiber connection or an asymmetric cable modem?

HI Scott - thanks for your reply.

As you can imagine i am not best pleased with the cable company.

Sorry I wasnt clear. It is a cable connection. That is - fibre to the street and co-axial in to the building. 50mb down 4mb up.

Perhaps I can private message you my IP’s to show you.?
I dont really want to post them for all to see.

The super hub modem/router has a section called “Static IP Subnet setup”

In there I give it my first static ip (81.x.x.1) that acts as the gateway address and I then set a subnet mask of

This then enables me to set my cisco router up with the second static ip 81.x.x.2 using 81.x.x.1 as the gateway address.

Does this help?

I have also just done a test call from pbx to my cell phone.

I ended the call on my pbx after 30 seconds. It did not disconnect on my cell phone.
I let the cell phone stay active for 60 secs.

I then checked the CDR of my trunk provider and I have indeed been billed for 60secs.

Yes, that’s just a router. No NAT involved. You have a /25 subnet of 128 IP’s to use it looks like.

You may be running NAT in the Cisco, and that is where the trouble starts.

If you want to PM that’s paid support. An option, again I think you should utilize if you want to make your date.

With static IP’s you should have no trouble getting this working.

What model Cisco?

Hi Scott yes I’m considering paid support on Monday. Do you think an hour is sufficient.
It’s a Cisco/linksys rv082 and has Ben working quite well until the superhub change.

Since your buiness is so small maybe try installing PFsense on an extra old machine? It is pretty easy to setup and will tell you whether it is the Cisco router messing with stuff.

I don’t think the RV’s support multiple public IP’s Could be wrong.

Are you sure you have 128 public IP’s? That seems very odd on a cable modem.

I can’t help with your problem as it’s over my head. I just wanted to say that I’ve used the paid support and was very pleased with it. They solved my issues quickly and professionally. I’m with Skyking on this one. You should use them.

And no… I’m not an employee, related to, nor connected with them in any way other than a previous customer.

Thanks for the replies SkykingOH and cdsJerryw, I think I will end up going down that road.

No I dont have 128 public ips. They have given me 7. I should have written

Ok, that makes a lot more sense. The 128 had me scratching my head.

I think you need to get an Enterprise class router that supports flexible NAT.

On the Open Source front you can’t do any better that PFSense.

Closed source the Juniper SSG5’s rock, it’s current production and I have seen new ones on eBay sub 350.

I would never have believed that the following could have had anything to do with the problems ive outlined in this thread.

I want to let everyone know, how it was solved, incase anyone else finds themselves in a similar position.

There is file in asterisk called:


It contains simple connection config options.
I assumed this meant I could move the CDR to another server.

So I edited it and had the CDR saved on a remote server.

The pbx still functioned, but would not hangup calls.

After a solid week of pain - google, freepbx forum, help and almost paid support…

the un-doing of this file and restoring it to localhost configuration FIXED everything.

I dont know why this allows it to work. But it does.



ps. Thanks to everyone that tried to help sort this out.

While I am glad that you got it working I don’t think that was the issue.

The CDR and SIP stack are two completely different modules.