IAX2 problem with Asterisknow 1.7.0

Has anyone experienced difficulty configuring IAX2 trunks with Asterisk 1.4.31 and FreePBX 2.7 and 2.8?

I have configured trunks in exactly the same way as I had done with Asterisk 1.4.22 but I cannot get them to function, Asterisk is sending a reject message even though routing is set up correctly.

Would be very grateful if someone could throw some light on this and let me know if they have been able to overcome this problem. Thanks in advance.

have a look at these iax2 settings that may be needed for your trunk:


and maybe


they were introduced somewhere close to 1.4.30 because of a security issue. I believe the default is yes thus the reject if not properly configured.


Thanks for the advice,requirecalltoken=auto has done the trick,1.4.31 and 1.4.22 are now communicating correctly. Strangely requirecalltoken=no did not fix the problem.

Thanks again

The fix I am using is to turn off token checking on 1.4.31 setups which makes them behave like earlier versions of asterisk. I put the following in Other Settings of Asterisk IAX Settings:


This made them general and applicable to all IAX2 trunks.

Hope this helps.