IAX Inbound on FreePBX 11


I’ve been trying to set an IAX inbound trunk on my FreePBX (asterisk
11.12.0) box (just moved from an asterisk 1.8 box) and when I make calls
to the number I get the error message about “Call rejected, CallToken
Support required.” and I’ve been through lots of pages on the internet
of people saying they have the same issue. I’ve tried all of the fixes
like setting calltokenoptional and requirecalltoken and the ones that I
believe should work and did on the old system now get rid of the "Call
Rejected error message but the calls never make it to any handsets.
Watching the asterisk cli shows me nothing when I call the number (it
doesn’t ring at all) no matter what verbosity I have set.

Any ideas guys/gals?


This also happens at random, an upgraded box will work for awhile then stop.

I found same thing, you will never see the call in the dial plan if it doesn’t get past a trunk or default context. Verbosity is dial plan debug.

try setting the IAX extension with
requirecalltoken = no

Thanks for the response. I’ve tried setting the requirecalltoken to no. When I do this it stops giving me the call token errors but nothing comes up in the CLI and it doesn’t ring anywhere. Any other ideas?

What do you mean ? IAX trunk to another asterisk box ?

You have to post some configs / logs so i can take a look