iax_custom.conf

An old system that I was supporting needed hw and sw upgrades. It had over two thousand iax extensions. The old system was AAH version 1.? and had been operational for 3 years. It was running on a Dell Optiplex GX270 with 1G RAM.
The upgraded system is running on a Dell PE1750, dual 2.8Ghz, 4G RAM.
Using PIAF with all latest updates:

  • Running Asterisk Version : Asterisk 1.4.21.2
  • Asterisk Source Version : 1.4.21.2
  • Zaptel Source Version : 1.4.12.1
  • Libpri Source Version : 1.4.7
  • Addons Source Version : 1.4.7
    The extensions on the old system had been done using the AMP (FreePBX) GUI but I did not want to install 2,000 extensions using the GUI so I just created all of them in iax_custom.conf. Things seemed to be working fine until we tried dialing from one extension to another extension. Although we can dial outbound on a trunk, the extension to extension calls fail. In trying to fix this, I created several iax & sip extensions using FreePBX and discovered that they can dial each other ok. It is just the extensions in iax_custom.conf that cannot dial each other. The log file shows this when it fails:

[Nov 12 14:32:34] VERBOSE[18750] logger.c: – dialparties.agi: dbset CALLTRACE/303378 to 300001
[Nov 12 14:32:34] VERBOSE[18750] logger.c: – dialparties.agi: Filtered ARG3: 303378
[Nov 12 14:32:34] VERBOSE[18750] logger.c: dialparties.agi: Setting default NOANSWER DIALSTATUS since no extensions available

And this is the log when it works:

[Nov 12 14:34:36] VERBOSE[18794] logger.c: – dialparties.agi: dbset CALLTRACE/300004 to 300001
[Nov 12 14:34:36] VERBOSE[18794] logger.c: – dialparties.agi: Filtered ARG3: 300004
[Nov 12 14:34:36] VERBOSE[18794] logger.c: – AGI Script dialparties.agi completed, returning 0
[Nov 12 14:34:36] DEBUG[18794] app_macro.c: Executed application: AGI
[Nov 12 14:34:36] VERBOSE[18794] logger.c: – Executing [[email protected]:7] Dial(“IAX2/300001-2004”, “IAX2/300004||tr”) in new stack

Any ideas would be appreciated.

there must have been something in the old system in extensions.conf (or equivalent custom files) to tell it how to dial those numbers. You will have to see how that is handled. You would probably be better off moving forward to get them into FreePBX. You may want to have a look at sasargen’s bulkextensions module to see if it may ease the setup process.

If you from asterisk CLI (asterisk -r) do:
database show AMPUSER
and
database show DEVICE
you probably only see the users and device that you created with the gui. All your extensions needs to be in the database to be able to call each other as the dial strings are in here.

As Philippe stated above, use the bulkextensions module to import all your extensions.
Download it from http://www.freepbx.org/trac/browser/contributed_modules/release/bulkextensions-0.2.1.tgz to your desktop, go to Module Administration and upload it then enable it so that you can select it from the menu. Now you can from the Bulkimport menu download a template that you can use Excel or OpenOffice Calc to populate, then import it back to FreepBX.

Mikael

Thanks for the advice guys. Actually the latest module download is http://freepbx.org/trac/browser/contributed_modules/release/bulkextensions-2.5.0.1.tgz . I have tested it and it works and it is a wonderful module - thanks to sasargen for creating and updating it. But I am wondering, what happened to the ability to create custom extensions in the xx_custom.conf files? I used to be able to do this and it would work.

Ron,
nothing happened to that ability. If it worked in the past, then you would have had to have some dialplan that would know how to call those extensions. To the best of my knowledge, there was never any such generic dialplan that knew hos to do such that came with FreePBX.