I would like to completely disable rewrite pjsip addressess

I have had a working system for five years, a recent update has changed how freepbx/asterisk is working with VPN connections

I have:

Office-A --> openvpn --> Office-B
10.1.1.15 ext321 10.0.99.2 <->10.0.99.1 192.168.100.15 FreePBX

I have been fighting with one way audio for awhile now. randomly the client will connect with

res_pjsip_registrar.c: Added contact ‘sip:[email protected]:49057;transport=UDP;rinstance=7a57149bf842a1f2’ to AOR ‘321’ with expiration of 60 seconds
17590 [2021-11-08 11:32:55] VERBOSE[4557] res_pjsip/pjsip_configuration.c: Endpoint 321 is now Reachable

And everything works perfectly, audio both ways and no drops

Most of the time though it will connect with

es_pjsip_registrar.c: Added contact ‘sip:[email protected]:49057;transport=UDP;rinstance=89f162414fd14318’ to AOR ‘321’ with expiration of 60 seconds
17596 [2021-11-08 11:32:55] VERBOSE[2346] res_pjsip/pjsip_configuration.c: Endpoint 321 is now Reachable

and obviously sending to the gateway will not allow return audio from the server. At this point I have tried all the various rport, rewrite, etc settings I can find in the forums. Nothing seems to change the random behavior

Almost forgot

PBX Version:

15.0.17.55

PBX Distro:

12.7.8-2107-3.sng7

Asterisk Version:

16.20.0

Purely from an Asterisk perspective, the rewrite_contact, rtp_symmetric, and force_rport options are what control such thing. When disabled then any IP address provided in signaling/SDP is used.