I need to install a module using Yum

I need to install a module using Yum. The reason is that somehow my module admin page is corrupted. Until I get that sorted out I desperately need to install the CallerID Management module. I have checked the repo list and schmooze-commercial is listed as one of the repos. Can someone give me the name of the module in the repo? Is that the correct repo?


Don’t follow the wrong path. RTF Wiki first.

To manage FreePBX modules you should use relevant CLI commands (if the GUI is not available or if you like this way) as written into the relevant Wiki page.

Don’t use YUM.

To discover FreePBX Modules locally installed (enabled/disabled) use:

amportal a ma list

To discover FreePBX Modules locally installed (enabled/disabled) and remotely available (online) use:

amportal a ma listonline

Geez, this was a last ditch effort to get a module installed until I figured out the gui issue. I checked no less that 12 installs that I have and ALL of them did not update the commercial modules so I could install callerid management. After I used the amportal commands to check the online list. Which it did not fine the callerid module, I went into the gui and did a check online and they were all there! There is some VOODOO in the ethernet! I checked several other locations and they are also working. Queue the spooky music here.

Thanks for the help. I will dig deeper into the wiki from now on.

So I still haven’t gotten to the end of this. If I use the command amportal a ma listonline from the SSH I do not get the module FaxPro listed. I am currently trying to install the Fax Pro module. How can I list the repositories that the system is listing. The response from the amportal a ma listonline shows that it is showing all th emodules selected in the GUI. I had all of them selected.

If you’re speaking of Core PBX and Commercial Modules’ repositories you can check them with a “yum repolist” and, specifically, by watching the /etc/yum.repos.d/FreePBX.repo file (and I think you just know that too).

Commercial Modules probably are downloaded as compressed files from another URL (they aren’t RPM).

By the way: is the Commercial Repository ("[schmooze-commercial]") enabled or not on the FreePBX.repo file?

Try also a “module_admin info faxpro”, you should note part of the module’s source location.

Do you have Zend PHP optimizer installed? are your systems FreePBX Distro based or what? which version of PHP your systems are running? have you checked the Wiki about that?

I checked the repolist and it does list schmooze-commercial with a status of 105. I checked the FreePBX.repo file and schmooze-commercial is enabled.

The version of FreePBX is the Distro from Schmooze and I am at 2.10.62-6 Where should I use the module_admin info faxpro ? PHP is at 5.3.3 Zend is installed.

All the publishers are:


Andrew Nagy
Mikael Carlsson

That is with the Commercial button checked.

Thanks for any help

I just thought of something. I got the license for FaxPro before I tried to install it. Would that make a difference? Although I am looking for the name Fax Pro in the modules section. It isn’t there. Fax Configuration is there tho. What section should it be in? Admin, Applications, Connectivity, Settings ?

Do all the Commercial modules come from Schmoozecom.com ? It seems that I have many to choose from to install except for the one I want to install. Similiar to the original problem of this thread.

I have done more comparing. I put up a fresh install of 2.11 on a system. I checked online for the modules and they were there in the module admin. I SSH into the new system and I ran amportal a ma listonline and they were listed. I went to one of my other systems that are experiencing this issue and when I used amportal a ma listonline I got two errors:

/usr/local/sbin/amportal: line 46: export: `-’: not a valid identifier

/var/lib/asterisk/bin/freepbx_engine: line 98: export: `-’: not a valid identifier
no repos specified, using: [standard,extended,unsupported,commercial] from last GUI settings
Are these errors the cause of my woes??


BTW, I swear I have not altered those files

What you mean with “I put up a fresh install of 2.11 on a system”?

Are you speaking about a “FreePBX Distro” or not?

I mean…if you’re trying a new version of “FreePBX Distro” to see in which way it behaves compared to previous ones why not trying directly with a FreePBX Distro 5.211.65-7 ISO right now?

It seems you’re speaking only about “FreePBX” forgetting the “FreePBX Distro” which, in case of FreePBX Commercial Modules deployment, is a mandatory requirement.

Have you read here?

All the installations have been the Freepbx Distro. I was told last night from TM100 that FaxPro isn;t available for version 2.10 although the info on the module in the store contradicts that. I will upgrade the system to 2.11 and see what happens.

It’s an interesting tip…maybe the Wiki should be arranged accordingly to state that (a sort of Interoperability Matrix between FreePBX Distro releases and Commercial Module releases).

We could make it available but in the previous thread you just kept talking about cid manager.

Upgrading the system to 2.11 did allow the FaxPro module to be installed. I guess in the future I will make sure the system is fully up todate when trying to install Commercial modules. Lesson Learned

Thanks for all the help