I need some help with a new install

Hi All,

Through a lot of searching I have discovered that this " retrieve_conf failed, config not applied" is a well documented problem unfortunately however I still have not been able to find a solution.

I’ll begin with my config: (All compiled from source downloaded from the site)

------------------------------------Config------------------------------------

FreePBX:
Feature Code Admin 2.7.0.0 FreePBX
FreePBX ARI Framework 2.7.0.1 FreePBX
FreePBX FOP Framework 2.7.0.0 FreePBX
FreePBX Framework 2.7.0.2 FreePBX
All modules are up to date.

Centos 5.5:
CentOS release 5.5 (Final)
Fully updated using yum

MySQL:
Server version: 5.0.77 Source distribution

phpmyadmin:
Version information: 3.3.3
Apache/2.2.3 (CentOS)

Asterisk:
== Parsing ‘/etc/asterisk/asterisk.conf’: == Found
== Parsing ‘/etc/asterisk/extconfig.conf’: == Found
== Binding iaxusers to odbc/asterisk/iaxusers
== Binding iaxpeers to odbc/asterisk/iaxpeers
== Binding sipusers to mysql/general/sip
== Binding sippeers to mysql/general/sip
== Binding sipregs to odbc/asterisk/sipregs
== Binding voicemail to mysql/general/voicemail_users
== Binding extensions to odbc/asterisk/extensions
== Binding meetme to mysql/general/meetme
== Binding queues to mysql/general/queues
== Binding queue_members to mysql/general/queue_members
== Binding musiconhold to mysql/general/musiconhold
== Binding queue_log to mysql/general/queue_log
Connected to Asterisk 1.6.2.8

----------------------------------Problem----------------------------------

Initial Error in popup window (After apply configuration button is clicked):

exit: 0

Checking for PEAR DB…OK
Checking for PEAR Console::Getopt…OK
Checking for /etc/amportal.conf …OK
Bootstrapping /etc/amportal.conf …OK
Parsing /etc/amportal.conf …OK
Parsing /etc/asterisk/asterisk.conf …OK
Connecting to database…OK
Connecting to Asterisk manager interface…OK
PHP Warning: Invalid argument supplied for foreach() in /var/www/html/admin/modules/callforward/functions.inc.php on line 64
PHP Warning: Invalid argument supplied for foreach() in /var/www/html/admin/modules/donotdisturb/functions.inc.php on line 47
PHP Warning: Invalid argument supplied for foreach() in /var/www/html/admin/modules/findmefollow/functions.inc.php on line 31
Added to globals: ASTETCDIR = /etc/asterisk
Added to globals: ASTMODDIR = /usr/lib/asterisk/modules
Added to globals: ASTVARLIBDIR = /var/lib/asterisk
Added to globals: ASTAGIDIR = /var/lib/asterisk/agi-bin
Added to globals: ASTSPOOLDIR = /var/spool/asterisk
Added to globals: ASTRUNDIR = /var/run/asterisk
Added to globals: ASTLOGDIR = /var/log/asterisk
Added to globals: CWINUSEBUSY = true
Added to globals: AMPMGRUSER = admin
Added to globals: AMPMGRPASS = adminsecure
Added to globals: AMPDBENGINE = mysql
Added to globals: AMPDBHOST = localhost
Added to globals: AMPDBNAME = asterisk
Added to globals: AMPDBUSER = asterisk
Added to globals: AMPDBPASS = adminsecure
Notice: no Devices defined
Notice: no Queues defined
Notice: no Conferences defined
Notice: no Parking Lots defined
Notice: no sip trunks defined
Notice: no iax trunks defined
Notice: no AMP Users defined
Please update your modules and reload Asterisk by visiting http://192.168.0.1/admin

1 error(s) occurred, you should view the notification log on the dashboard or main screen to check for more details.

Error in FreePBX Notices:

retrieve_conf failed, config not applied
Reload failed because FreePBX could not connect to the asterisk manager interface.
Added 1 minute ago
(freepbx.RCONFFAIL)

I have followed many tutorials and made sure that I haven’t left any steps out when setting up.
I’ve checked over and over that username/passwords match to the correct *.conf’s
I’ve made sure that my DB’s are setup correctly according to tutorials:

asterisk (compiled by sample scripts)
asteriskcdrdb (compiled by sample scripts)


Server Status in FreePBX:
Asterisk: ERROR
Ops Panel: WARN
MySQL: OK
Web Server: OK
SSH Server: WARN

Memory Limit has been changed

Things where I think I might have gone wrong:

I’ve tried to apply the correct permissions to the correct folders taken from various tutorials most notably:
http://www.powerpbx.org/content/create-user-and-set-permissions-centos-v5x-asterisk-v14x-freepbx-v24x

I’ve made sure that Asterisk is running as user asterisk (I’d be happy for you to show me how to verify)

Apache running as user asterisk (Again, please tell me how to verify)

Please ask if you need any more info such as version numbers etc i’ll be happy to give them to you as long as you show me how!

Why I eventually decided to post: I’ve had a week to build this and deadline is coming up soon. My eyes are bleeding from searching google! I really need your help!

Thanks!
Ross

Thanks peter,

It was indeed a conflict in usernames and passwords in the httpd.conf file.

Thanks for your help

First, check you httpd. Perhaps do something like:
[[email protected] ~]# grep asterisk /etc/httpd/conf/httpd.conf
User asterisk
Group asterisk

IP addresses. This is indicated by the asterisks in the directives below.

[[email protected] ~]# ls -asl /var/lib/php/session
total 4
4 -rw------- 1 asterisk asterisk 1293 Jun 8 20:41 sess_uuq303bnnp1a97la3if441ir23
[[email protected] ~]#

The AMI error you have is interesting. It’s like the admin secret in /etc/asterisk/manager.conf doesn’t match the AMPMGRPASS in /etc/amportal.conf.

Try these things and see where you get.

Thanks peterbokunet,

The box went back into a production environment with an old working elastix setup. As soon as I can get the change request to take it back down i’ll reply with the outcome of your suggestions.

Speak with you soon!