I need help with music on hold, sometimes it works sometimes not

Hey everyone. MOH drives me insane not sure what I’m doing wrong. In the /var/lib/asterisk/moh folder I have the default ones and folders. After doing a bunch of changes and trying different file formats, I got it working by putting a hold WAV into the /moh/music-on-hold folder. The problem is I tried to change it, but uploading a new file there did nothing! I even deleted the file that was there, and it still plays the old music. I rebooted asterisk and same thing, it plays the old hold music even though it’s no where to be found in the /var/lib/asterisk/moh . The odd thing is when I go to Music on Hold in the FreePBX portal it doesn’t even list the music-on-hold folder that I had before either. Where could the music be coming from? It took me FOREVER to make it work the first time, like it would show the music file there but do nothing then finally would start to work. Is there something I’m missing here? My issue was I wanted to reduce the volume of the hold music, so I downloaded it edited it and re-uploaded it but nothing changed. So I deleted the file as a test and it still plays the music so I’m at a loss!

One correction:

8000Hz is 8Khz not 8Mhz…

Thanks for your help. It’s so weird because originally I tried every program, sox, etc to make it PCM 8000Hz 16 bit mono, following guides etc online, but they would never play even though they were in the right format. Then suddenly it would just start. Sometimes reuploading the file would just do it so it’s weird. It’s freePBX 2.8.0 it says. Asterisk is also. It’s weird when I had the issue before I tried using default etc, nothing would work. Now I only have the one file there but it plays something else, so strange. I want to get it to work then never change it, it’s just SO loud right now that people complain lol.

Hi there oshkosh.

First of all let people know which version of asterisk/FreePBX you are using, it will help the experts determine if you are experiencing something they have seen before (by the way, I am no expert).

I had issues with MOH and because my system was just being built I took the easy option and upgraded to asterisk 1.8 (see http://www.freepbx.org/forum/freepbx/users/asterisk-1-8-will-it-break-anything )

I dont advocate you do the same!

I got frustrated and found this the easy option. I saw similar issues to yourself, but did find that if I added .wav files to the ‘default’ MOH class that it would be played. Maybe you could try this as some diagnostics and report your results?

The other thing to note is the format of the music, what seems to work well is wav files PCM uncompressed 8000 Hz (or 8MHz depending on how you read it) 16 bit and Mono. Dont even bother with MP3 until you have got it working with wav…

Of course, as I say, I am no expert, I am happy to be contradicted by anyone!