I need help with freepbx and asterisk

i just installed freepbx 12 on ubuntu 14.04.
i tried to install freepbx 13 on ubuntu 16.04 and centos 7, but idk why, the installation will always fail in the end with “cannot connect with asterisk” or something like that.
now that i have it running i got to a new issue, when i try to apply the config to add the extensions, i get this error:

Reload failed because retrieve_conf encountered an error: 126

exit: 126
sh: 1: /var/lib/asterisk/bin/retrieve_conf: Permission denied

can you help me with it?

thank you!

Sounds like you do not have permission to write to the file with the user that is attempting (asterisk?)

Is there a reason you decide to start with the “expert” install instead of using the SNG7 based Distribution? It handles all of these problems and gets you a working system at the outset.

To answer your question, try running “fwconsole chown” at the system console and see if that helps.

Ok, well, How can I fix it?
Thank you

Well this is the what happened after I ran the command:
-bash: fwconsole: command not found

Well, the reason is that I can’t install using an iso on my vps hosting provider.

Thank you!

OK - makes sense. Which VPS are you using? Lots of people have had lots of success installing the FreePBX distro on various platforms.

If you can give us more information, I’m sure someone would be willing to help you get this working. BTW - did you check the FreePBX Wiki pages? There is lots of information out there, including several sections that talk to ‘bare metal’ installs

Well, I installed it by the tutorial in the freePBX wiki.

My vps is from vpscheap.net, I have the 1 GB ram and 30 GB of disk space.

Freepbx 12 does not have fwconsole.

amportal chown

The minimum comfortable system requirements for the system are 4G RAM and 120G of disk space. While you seem very committed to this installation, I would still highly recommend getting onto a platform that is better suited to running a PBX. SIPStation (a division of Sangoma) comes to mind. If you look back through the forums, you’ll see lots of people with lots of PBX experience running into problems.

1 Like

Let’s be clear on something. FreePBX 12 has been EOL for over three years now. It is completely unsupported not the mention this is a manual install. So we have no idea what has actually been done by you and how it was done.

In fact at this point Distro 6 (what FreePBX 13) was built on is also EOL. FreePBX 13 has support left too it but even then FreePBX 14 is the current release with 15 down the pipe in the next 3-6 months.

If you’re going to install a new PBX try using the current software release and not software that even the vendor is going to say “Its unsupported, we can’t help”

Good evening.
Please, rename the file /var/spool/cron/asterisk, restart the system and check that the button Apply works.

Rename to what?

Anything like asterisk_. When the system restarts, it will be regenerated.

Well, I renamed it to asterisk.bak, I restarted the system, but I still get the same error when I apply the config

Have you done that yet? You never confirmed.

sorry, i missed your reply,
this is the output of the command:

Please wait…

Removing any dangling symlinks
Dangling symlinks removed

but still, when i click the apply config button, i get the same error:

Reload failed because retrieve_conf encountered an error: 126

exit: 126
sh: 1: /var/lib/asterisk/bin/retrieve_conf: Permission denied

Is there a link or option for “View More Details” when that comes up? If there are, use it and provide that information.

this is in the view more:

exit: 126
sh: 1: /var/lib/asterisk/bin/retrieve_conf: Permission denied

i have an update,
i left vpscheap and i moved to digital ocean, i have successfully installed FreePBX, now i have a new problem, port 5060 is not open, i can see that its there with netstat -na |grep 5060
udp 0 0*
but when i use nmap localhost it shows me this:
Starting Nmap 6.47 ( http://nmap.org ) at 2018-10-20 23:04 UTC
Nmap scan report for localhost (
Host is up (0.0000060s latency).
Not shown: 995 closed ports
22/tcp open ssh
25/tcp open smtp
80/tcp open http
111/tcp open rpcbind
3306/tcp open mysql

Nmap done: 1 IP address (1 host up) scanned in 1.68 seconds

Because nmap is TCP by default, you have to tell it to scan UDP. At this point since you’re jumping around host companies and you clearly are out of your depth with doing a manual install. Go to some place like vultr.com where the FreePBX Distro actually can be installed and is part of their ISO library.

1 Like