I have a problem with a outbound trunk


I created a trunk and the outbound route. If I make a call it doesnt work. That is because Asterisk is sending “56945013154@telvoip” as number. The correct number is “56945013154” (without “@telvoip”).

   -- Executing [s@macro-dialout-trunk:30] Dial("PJSIP/1001-0000006f", 
"SIP/telvoip/56945013154@telvoip,300,T") in new stack
  == Using SIP RTP TOS bits 184
  == Using SIP RTP CoS mark 5
    -- Called SIP/telvoip/56945013154@telvoip

– Called SIP/telvoip/56945013154@telvoip
Must be:
– Called SIP/telvoip/56945013154

If I make a call direct from Asterisk CLI, it works properly.
channel originate SIP/telvoip/56945013154 extension 1001

I guess this is a configuration problem. I’ve been trying to fix this, but I could not. How can I fix it?



You are in freepbx forum, what are you put in menu “connectivity/trunks//sip settings/incomming/register string” ?