I fixed a problem (no DID in CDR for incoming Google Voice) and now FreePBX is warning me about the "tampered" module

This feels like déjà vu all over again! (I think that was a Yogi Berra-ism).

I noticed that on my system, when I view CDR reports no DID is reported on incoming calls on Google Voice trunks. I fixed this by going into /var/www/html/admin/modules/motif/functions.inc.php and adding a line, but now FreePBX is warning me that I have a tampered file. Well I know that, because I’m the one who tampered with it. After the last thread I was involved in that had to do with module security I’m getting a sinking feeling that getting rid of that warning will be another problem. I hope not, but I would like to keep getting the DID in the CDR reports.

The fix is very obvious, even to me and I’m not a programmer. After the line that reads:

$ext->add($incontext, $address, '1', new ext_noop('Receiving GoogleVoice on DID: '.$list['phonenum']));

I added:

$ext->add($incontext, $address, '', new ext_setvar('CDR(did)', $list['phonenum']));

That fixes the problem, and once you reload the configuration the DID appears properly on new incoming GV calls. I’d like to keep using this, but is there any way to keep FreePBX from warning me about it, since I already know and made the change deliberately? If you recall the previous thread you know that I am extremely adverse to signing any legal forms, so please don’t say I need to sign for a new key!

I’d like to see the distribution version of the Google Voice (Motif) module fixed if possible, but in the meantime is there any way I can get rid of that warning?

Think you found a bug? then open a ticket at issues.freepbx.org , that is where bugs and features are officially submitted to FreePBX.

IDEA : Dashboard Statistics to display meaningful data on x axis :wink:

Added here, hope it is what you need:

http://issues.freepbx.org/browse/FREEPBX-9211

I can click the X in the corner of the alert window to hide the alert as you say, but every time I log out and then log back it it reappears:

I need to clarify one thing about this issue. It appears that some incoming Google Voice calls were getting the DID correctly set, and some were not. If the call gets as far as one of the [ext-did-000?] contexts then it appears the DID does get set. However if the call gets diverted before then, it does not. Where this is particularly noticeable is if the call winds up being blacklisted. You can see that the call came in, but you have no idea what DID it came in on. The added line assures that the DID is set practically as soon as the call arrives.

That’s a bug that SHOULD be fixed, that we only realised was there a few days ago – See http://issues.freepbx.org/browse/FREEPBX-9190 – Can you check to make sure that you’re running the latest framework and dashboard?

I just logged in again and got the warning box pictured in my previous post. I clicked the X to close the box. I then went to module admin to check the versions, and it showed:

FreePBX Framework 12.0.62 Stable FreePBX GPLv2+ Enabled
System Dashboard 12.0.29 Stable FreePBX AGPLv3+ Enabled

I then did an online check for new modules, and Framework had an update. After the updates:

FreePBX Framework 12.0.63 Stable FreePBX GPLv2+ Enabled

I then logged out of FreePBX and closed the browser tab, then logged back in, and the warning box was back. I clicked on the X to close it again, just to be certain the Framework update was in place, logged out and closed the browser tab, and logged in again, and once again the warning was back.

What’s a bit unusual is that in Firefox, if I log out and then log back in without closing the browser tab, it seems the warning stays off. But if I log out and then close the browser tab and then log back in (in a new tab) the warning comes back. I tested this several times to verify that behavior. Not sure what that means or why it happens, it’s just an observation. I didn’t pause very long between attempts, which might have made a difference.

EDIT: I just re-read that issue and realized it’s cookie-based, and I have a Firefox addon installed that deletes cookies when a tab is closed unless I “whitelist” a site, and I had forgot to whitelist the server. After allowing it to save cookies, the warning no longer appears! Sorry that I hadn’t realized it could be a cookie issue.

2 Likes

100% that is not intended behaviour. Can you comment on that ticket to say it’s NOT working? (then you’ll get email notifications).

All I can say is that @tm1000 and I can’t duplicate it 8-\

If you’ve got some time, could you jump into IRC and chat with us there, and we’ll see if we can figure out what’s causing it?

I’ve tried this so many different ways.

  • I edited one file in cdr
  • I then logged out
  • closed the browser
  • tested in firefox and chrome
  • checked online
  • apply changes

Nothing brings the banner back. (we are talking about the banner right)

Nevermind problem solved:

1 Like

I edited the end of my previous post - it dawned on me that I had cookies disabled when I close tabs, except for sites I’ve allowed to save cookies. Which I did for the FreePBX server, so it’s all good now!. Thanks

1 Like

Sorry to say you’ll still get the nightly emails. I will resolve your bug tomorrow.

Thanks, I appreciate that!

Fixed in Motif 12.0.4

Downloaded and installed it, works great. Thanks!