I can't create new Inbound Routes

Hello, and excuse me for my bad english…

I use the actual svn form freepbx V2.2 Beta 1. Whenever i create a new or modify a Inbound Route, the following error-message comes:

INSERT INTO incoming (cidnum,extension,destination,faxexten,faxemail,answer,wait,privacyman,alertinfo, channel, ringing) values (’’,‘22’,‘ext-queues,500,1’,‘default’,’’,‘0’,’’,‘0’,’’, ‘’, ‘’) [nativecode=1054 ** Unknown column ‘ringing’ in ‘field list’]

What can i do? Is this an incompatible Module? Please help me, i must create new Routes.

Thank you,

Thomas

The same problem happen to me after doing a svn upgrade to 2208.
Below are the log messages I got on the console.

Jakob

[[email protected] ~]# cd /usr/src/freepbx/
[[email protected] freepbx]# svn update
U amp_conf/astetc/extensions.conf
U amp_conf/htdocs_panel/safe_opserver
U amp_conf/htdocs/admin/modules/core/page.extensions.php
U amp_conf/htdocs/admin/modules/core/functions.inc.php
U SQL/newinstall.sql
U SQL/newinstall.sqlite.sql
U upgrades/2.2.0beta1/tables.php
Updated to revision 2208.

[[email protected] freepbx]# ./install_amp --force=2.2.0
Checking for PEAR DB…OK
Checking for PEAR Console::Getopt…OK
Checking user…OK
Checking for /etc/amportal.conf…OK
Reading /etc/amportal.conf…OK
Checking for /etc/asterisk/asterisk.conf…OK
Reading /etc/asterisk/asterisk.conf…OK
Checking for Asterisk 1.2…OK
Checking for selinux…OK
Connecting to database…OK
Checking current version of AMP…2.2.0beta1
Installing new AMP files…OK
Configuring install for your environment…OK
Setting permissions on files…OK
Checking for upgrades…0 found
Generating AMP configs…
Generating Configurations.conf…
Checking for PEAR DB…OK
Checking for PEAR Console::Getopt…OK
Checking for /etc/amportal.conf…OK
Reading /etc/amportal.conf…OK
Reading /etc/asterisk/asterisk.conf…OK
Connecting to database…OK

SELECT extension, directdid, didalert, faxexten, faxemail, answer, wait, privacyman FROM users WHERE directdid IS NOT NUL
L AND directdid != ‘’ [nativecode=1054 ** Unknown column ‘faxexten’ in ‘field list’]Generating AMP configs…OK
Restarting Flash Operator Panel…OK