I cannot receive incoming calls / allowing guest is a problem

hello community,

I have a Pbx (Server) where I cannot receive incoming calls when I have Allow guest and Anonymous SIP call set to “NO”.

They only work when I set them to “YES” but this is a terrible problem because I get a lot of fake calls and attacks on my Freepbx.

What can I do to avoid these attacks?

What can I do so that my calls come in when I have NO enabled?

If someone is so nice, please help me !!!

How did you set up your trunks?

Please paste Asterisk log for a rejected call, as requested in your other thread.

What problem are you trying to solve with allowguest? The only obvious problem would be that you would otherwise need to define too many incoming trunks, in which case the solution is to upgrade to chan_pjsip. If you have already answered in your previous thread, that is why you should not start new threads on the same topic.

Solve the underlying problem, as above, or whitelist allowable sources in your firewalls.

That depends on your answer to the first question.

trixboxCLI> sip set debug on
Usage: sip set debug
– Executing [5025…XX (PHONE)@from-internal:1] Macro(“SIP/501-08842a08”, “user-callerid|SKIPTTL|”) in new stack
– Executing [[email protected]:1] NoOp(“SIP/501-08842a08”, “user-callerid: device 501”) in new stack
– Executing [[email protected]:2] Set(“SIP/501-08842a08”, “AMPUSER=501”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/501-08842a08”, “0?report”) in new stack
– Executing [[email protected]:4] ExecIf(“SIP/501-08842a08”, “1|Set|REALCALLERIDNUM=501”) in new stack
– Executing [[email protected]:5] NoOp(“SIP/501-08842a08”, “REALCALLERIDNUM is 501”) in new stack
– Executing [[email protected]:6] Set(“SIP/501-08842a08”, “AMPUSER=501”) in new stack
– Executing [[email protected]:7] Set(“SIP/501-08842a08”, “AMPUSERCIDNAME=Test”) in new stack
– Executing [[email protected]:8] GotoIf(“SIP/501-08842a08”, “0?report”) in new stack
– Executing [[email protected]:9] Set(“SIP/501-08842a08”, “AMPUSERCID=501”) in new stack
– Executing [[email protected]:10] Set(“SIP/501-08842a08”, “CALLERID(all)=“Test” <501>”) in new stack
– Executing [[email protected]:11] Set(“SIP/501-08842a08”, “REALCALLERIDNUM=501”) in new stack
– Executing [[email protected]:12] ExecIf(“SIP/501-08842a08”, “0|Set|CHANNEL(language)=”) in new stack
– Executing [[email protected]:13] NoOp(“SIP/501-08842a08”, “TTL: ARG1: SKIPTTL”) in new stack
– Executing [[email protected]:14] GotoIf(“SIP/501-08842a08”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,23)
– Executing [[email protected]:23] NoOp(“SIP/501-08842a08”, “Using CallerID “Test” <501>”) in new stack
– Executing [5025…XX (PHONE)@from-internal:2] Set(“SIP/501-08842a08”, “_NODEST=”) in new stack
– Executing [5025…XX (PHONE)@from-internal:3] Macro(“SIP/501-08842a08”, “record-enable|501|OUT|”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/501-08842a08”, “0?2:4”) in new stack
– Goto (macro-record-enable,s,4)
– Executing [[email protected]:4] AGI(“SIP/501-08842a08”, “recordingcheck|20220111-182612|1641947172.2429”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck
recordingcheck|20220111-182612|1641947172.2429: Outbound recording not enabled
– AGI Script recordingcheck completed, returning 0
– Executing [[email protected]:5] NoOp(“SIP/501-08842a08”, “No recording needed”) in new stack
– Executing [5025…XX (PHONE)@from-internal:4] Macro(“SIP/501-08842a08”, “dialout-trunk|1|5025…XX (PHONE)||”) in new stack
– Executing [[email protected]:1] Set(“SIP/501-08842a08”, “DIAL_TRUNK=1”) in new stack
– Executing [[email protected]:2] ExecIf(“SIP/501-08842a08”, “0|Authenticate|”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/501-08842a08”, “0?disabletrunk|1”) in new stack
– Executing [[email protected]:4] Set(“SIP/501-08842a08”, “DIAL_NUMBER=5025…XX (PHONE)”) in new stack
– Executing [[email protected]:5] Set(“SIP/501-08842a08”, “DIAL_TRUNK_OPTIONS=tr”) in new stack
– Executing [[email protected]:6] Set(“SIP/501-08842a08”, “GROUP()=OUT_1”) in new stack
– Executing [[email protected]:7] GotoIf(“SIP/501-08842a08”, “1?nomax”) in new stack
– Goto (macro-dialout-trunk,s,9)
– Executing [[email protected]:9] GotoIf(“SIP/501-08842a08”, “0?skipoutcid”) in new stack
– Executing [[email protected]:10] Set(“SIP/501-08842a08”, “DIAL_TRUNK_OPTIONS=”) in new stack
– Executing [[email protected]:11] Macro(“SIP/501-08842a08”, “outbound-callerid|1”) in new stack
– Executing [[email protected]:1] ExecIf(“SIP/501-08842a08”, “0|SetCallerPres|”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/501-08842a08”, “1?start”) in new stack
– Goto (macro-outbound-callerid,s,4)
– Executing [[email protected]:4] NoOp(“SIP/501-08842a08”, “REALCALLERIDNUM is 501”) in new stack
– Executing [[email protected]:5] GotoIf(“SIP/501-08842a08”, “1?normcid”) in new stack
– Goto (macro-outbound-callerid,s,10)
– Executing [[email protected]:10] Set(“SIP/501-08842a08”, “USEROUTCID=”) in new stack
– Executing [[email protected]:11] Set(“SIP/501-08842a08”, “EMERGENCYCID=”) in new stack
– Executing [[email protected]:12] Set(“SIP/501-08842a08”, “TRUNKOUTCID=My company” ") in new stack
– Executing [[email protected]:13] GotoIf(“SIP/501-08842a08”, “1?trunkcid”) in new stack
– Goto (macro-outbound-callerid,s,17)
– Executing [[email protected]:17] GotoIf(“SIP/501-08842a08”, “0?usercid”) in new stack
– Executing [[email protected]:18] Set(“SIP/501-08842a08”, "CALLERID(all)=My company. ") in new stack
– Executing [[email protected]:19] GotoIf(“SIP/501-08842a08”, “1?report”) in new stack
– Goto (macro-outbound-callerid,s,23)
– Executing [[email protected]:23] NoOp(“SIP/501-08842a08”, "CallerID set to “My Company.” ") in new stack
– Executing [[email protected]:12] AGI(“SIP/501-08842a08”, “fixlocalprefix”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/fixlocalprefix
== fixlocalprefix: Dialpattern NXXNXXXXXX matched. 5025…XX (PHONE) → 5025…XX (PHONE)
– AGI Script fixlocalprefix completed, returning 0
– Executing [[email protected]:13] Set(“SIP/501-08842a08”, “OUTNUM=5025…XX (PHONE)”) in new stack
– Executing [[email protected]:14] Set(“SIP/501-08842a08”, “custom=ZAP/g0”) in new stack
– Executing [[email protected]:15] GotoIf(“SIP/501-08842a08”, “1?gocall”) in new stack
– Goto (macro-dialout-trunk,s,17)
– Executing [[email protected]:17] Macro(“SIP/501-08842a08”, “dialout-trunk-predial-hook|”) in new stack
– Executing [[email protected]:18] GotoIf(“SIP/501-08842a08”, “0?bypass|1”) in new stack
– Executing [[email protected]:19] GotoIf(“SIP/501-08842a08”, “0?customtrunk”) in new stack
– Executing [[email protected]:20] Dial(“SIP/501-08842a08”, “ZAP/g0/5025…XX (PHONE)|300|”) in new stack
– Requested transfer capability: 0x00 - SPEECH
– Called g0/5025…XX (PHONE)
– Zap/1-1 is proceeding passing it to SIP/501-08842a08
– Zap/1-1 is making progress passing it to SIP/501-08842a08
– Channel 0/1, span 1 got hangup request, cause 31
– Hungup ‘Zap/1-1’
== Everyone is busy/congested at this time (1:0/0/1)
– Executing [[email protected]:21] Goto(“SIP/501-08842a08”, “s-CHANUNAVAIL|1”) in new stack
– Goto (macro-dialout-trunk,s-CHANUNAVAIL,1)
– Executing [[email protected]:1] GotoIf(“SIP/501-08842a08”, “1?noreport”) in new stack
– Goto (macro-dialout-trunk,s-CHANUNAVAIL,3)
– Executing [[email protected]:3] NoOp(“SIP/501-08842a08”, “TRUNK Dial failed due to CHANUNAVAIL - failing through to other trunks”) in new stack
– Executing [5025…XX (PHONE)@from-internal:5] Macro(“SIP/501-08842a08”, “outisbusy|”) in new stack
– Executing [[email protected]:1] Playback(“SIP/501-08842a08”, “all-circuits-busy-now|noanswer”) in new stack
– <SIP/501-08842a08> Playing ‘all-circuits-busy-now’ (language ‘en’)
– Executing [[email protected]:2] Playback(“SIP/501-08842a08”, “pls-try-call-later|noanswer”) in new stack
– <SIP/501-08842a08> Playing ‘pls-try-call-later’ (language ‘en’)
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
– Executing [[email protected]:3] Macro(“SIP/501-08842a08”, “hangupcall”) in new stack
– Executing [[email protected]:1] ResetCDR(“SIP/501-08842a08”, “w”) in new stack
– Executing [[email protected]:2] NoCDR(“SIP/501-08842a08”, “”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/501-08842a08”, “1?skiprg”) in new stack
– Goto (macro-hangupcall,s,6)
– Executing [[email protected]:6] GotoIf(“SIP/501-08842a08”, “1?skipblkvm”) in new stack
– Goto (macro-hangupcall,s,9)
– Executing [[email protected]:9] GotoIf(“SIP/501-08842a08”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,11)
– Executing [[email protected]:11] Hangup(“SIP/501-08842a08”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 11) exited non-zero on ‘SIP/501-08842a08’ in macro ‘hangupcall’
== Spawn extension (macro-hangupcall, s, 11) exited non-zero on ‘SIP/501-08842a08’ in macro ‘outisbusy’
== Spawn extension (macro-hangupcall, s, 11) exited non-zero on ‘SIP/501-08842a08’
trixbox
CLI> sip set debug off
SIP Debugging Disabled

I’m not that person you answered

Friend if I use pjsip how can I avoid those attacks?

I just want help to receive my calls without attacks,

help me

I just hit the debug,

Do you need anything else?

I cannot receive incoming calls when I have Allow guest and Anonymous in ¨Yes¨¨

Please help me, I just wish I could leave my Freepbx without attacks

PJSIP allows you to avoid one of the reasons that people feel they need to use allowguest=yes with chan_sip, as it allows you to have multiple match lines in the type=identify section, and those can match whole sub-networks…

If that is not the reason you are using allowguest=yes, please explain why you are doing so.

I’m using “allowguest = yes” because I can’t find a way to receive incoming calls without having that enabled.

Why are you not able to receive incoming calls without it?

That’s what I want to know, it seems strange to me that it does not work without that option

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.