I can not register two sip phone

Hi.
I am newbie here.
I have defined two extensions as as simple as possible from freepbx gui installed on a raspberry pi 3b board but they could not be registered.

Notice [11898]:…request ‘register’ from …failed for…
No matching endpoint.

Could anyone kindly help me?

By default, recent versions of FreePBX use port 5060 for pjsip and port 5160 for chan_sip.

It appears that you set up the extensions on chan_sip but they are attempting to connect to port 5060.

You can either:

  1. Change the extensions to use pjsip.
  2. Change the configurations of your devices to connect to port 5160.
  3. In Asterisk SIP Settings, put pjsip on a different port and move chan_sip to port 5060. After this change, restart (not just reload) Asterisk.
1 Like

Thank you that is worked.
Alongside this, I have installed asterisk myself, on a raspbian os.
This problem is exist there.
Should it be a same problem?

Sorry, I don’t know the default settings for Asterisk without a GUI.

The chan_sip setting is e.g.
bindport=5160
and is likely in /etc/asterisk/sip.conf

For pjsip, it’s e.g.
bind=0.0.0.0:5060
and is likely in /etc/asterisk/pjsip.transports.conf

If you don’t find them there, search for ‘bind’ in all files in /etc/asterisk

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.