I Can Not Make and Receive Calls on Freepbx 15

Post a call log

Here is the call log/trace on pastebin


That’s an inbound call not an outbound.

Anyway, for the inbound call, it seems it is going to a queue. Try directing it to an extension so you can avoid any queue misconfiguration.

Paste an outbound call so we can see what is happening.

So sorry about that, here is a call log for outgoing.

I will direct the call to extensions to see how it goes and post the log too.

So you are trying to dial a number with 11 digits. Delete all patterns from your current outbound route and create only one pattern with 11 Xs like this XXXXXXXXXXX

That pattern should match any 11 digits number

Try with that pattern

Use a pattern that can match numbers of variable length, such as
(Note the dot at the end.)


Wow you are such a genius @arielgrin
it is now calling out!!
I appreciate you so much.

Who would have known.

Can we move to the inbound calls now?

Thank you, it worked fine.

Great you got outbound working. Remember that the pattern with 11Xs will exclusively match 11 digits numbers.

Regarding inbound, have you tried directing the call to an extension instead of a queue?

Yes I did this and this is the call log.


Your inbound route still points to some kind of queue.
Delete the inbound route and create a new inbound route. Don’t modify anything on the new route, just set the destination to a real extension that it is actually connected and registered and try again.
It seems that there is an extension 209 that is not currently registered but you are trying to send the call to that extension.

You are truly the man, it rang on the extension and here is the call log

But I really wanted it to ring on all the 30 extensions I have setup, what do I do?

All 30 extensions? If I were you I wouldn’t do that, but probably you have a valid need for that.

Two ways to do it; either create a ring group or a queue with all the extensions that you wish. Main difference between those, basically a ring group is just a way of ringing multiple extensions at the same time but just that, a queue is a “sophisticated” piece of logic that lets you establish priorities, waiting times and some other stuff. The queue answers the call and administers it, the ring group doesn’t.

Once you created either of those, point your inbound route to it.

As an end note, you should go and read the wiki, you will find a lot of info there, in fact all your questions in this thread could have been easily answered by the wiki, and that way you will have the satisfaction of figuring it out all by yourself.

Thank you so much for your time and advises, I really appreciate.
I did read the wiki and all but sometimes just reading may let you spend years on the problem when someone more experienced can just point you in the right direction.

I was able to create the ring groups and linked all the extensions to the ring groups but it still didnt ring.
Here is the call log

It seems you have some kind of error with your extensions. There are a lot of errors regarding unregistered extensions. I think you might have misconfigured something.

How do I show you my configuration, maybe you can see what was misconfigured.

Well at this point I think you need to start reading a little bit by your own. I could only help you if you are wishing to share your desktop with Anydesk.

At this point I dont mind sharing it with you.
I will keep reading, but I have been on the issue for days now.

Hello please I need help,

I still cant call in, can anyone help me?
Here is a call trace https://pastebin.com/e2mfk9qC

When I setup chan_sip extensions they fail to register on the sofphone (forbidden) there for no inbound or outbound calls, I also change chan_sip to listen on 5060 in sip settings and set pjsip to listen on 5160.

This doesn’t help so I revert and I can make calls out but I still cant receive calls on the extension.

Please help, anyone?