I am unable to hear caller's voice!, but the caller able to hear my voice

Hello All,

My asterisk is behind firewall.(asterisk 1.8.4, freepbx 2.9)
I have configured my firewall to allow asterisk’s ports below:

5060 (tcp)
5060 (udp)
4569 (udp)
10001:20000 (udp)
5038 (tcp)

my problem is:

when call comes in, I am unable to hear caller’s voice!, but the caller able to hear my voice… and then the call was dropped after 30 seconds

could any body please help?

thanks a lot in advance


There are many articles on Asterisk and NAT. You need to have your localnet and externip variables set correctly.

Since you did not even tell us what system you are running I can’t even tell you where to look.

I am running asterisk 1.8.4 and FreePBX 2.9…
could you please help?

Just go into the SIP settings module and configure your NAT options.

hi… what nat options should I configure>

I had:

externip = X.X.X.X
fromdomain = yourdomain.com
localnet = 192.168.X.0/

but still not working…
what I missed?

Where is this data located? Did you use the sip settings module?

Does the ‘sip show settings’ command display the correct info?

You can also try the ‘rtp debug’ command to see the destination IP of the media. Don’t forget to turn it off or your logs will fill up fast!

sip show settings shown below:

hmm … what I missed??

Global Settings:

UDP Bindaddress:
TCP SIP Bindaddress: Disabled
TLS SIP Bindaddress: Disabled
Videosupport: No
Textsupport: No
Ignore SDP sess. ver.: No
AutoCreate Peer: No
Match Auth Username: No
Allow unknown access: Yes
Allow subscriptions: Yes
Allow overlap dialing: Yes
Allow promsic. redir: No
Enable call counters: No
SIP domain support: No
Realm. auth: No
Our auth realm asterisk
Use domains as realms: No
Call to non-local dom.: Yes
URI user is phone no: No
Always auth rejects: Yes
Direct RTP setup: No
User Agent: FPBX-2.9.0(
SDP Session Name: Asterisk PBX
SDP Owner Name: root
Reg. context: (not set)
Regexten on Qualify: No
Caller ID: Unknown
From: Domain: mydomain.com
Record SIP history: Off
Call Events: Off
Auth. Failure Events: Off
T.38 support: No
T.38 EC mode: Unknown
T.38 MaxDtgrm: -1
SIP realtime: Disabled
Qualify Freq : 60000 ms
Q.850 Reason header: No

Network QoS Settings:

IP ToS RTP audio: EF
IP ToS RTP video: AF41
IP ToS RTP text: CS0
802.1p CoS SIP: 4
802.1p CoS RTP audio: 5
802.1p CoS RTP video: 6
802.1p CoS RTP text: 5
Jitterbuffer enabled: No
Jitterbuffer forced: No
Jitterbuffer max size: -1
Jitterbuffer resync: -1
Jitterbuffer impl:
Jitterbuffer log: No

Network Settings:

SIP address remapping: Enabled using externaddr
Externrefresh: 10

Global Signalling Settings:

Codecs: 0xe (gsm|ulaw|alaw)
Codec Order: ulaw:20,alaw:20,gsm:20
Relax DTMF: No
RFC2833 Compensation: No
Symmetric RTP: Yes
Compact SIP headers: No
RTP Keepalive: 0 (Disabled)
RTP Timeout: 30
RTP Hold Timeout: 300
MWI NOTIFY mime type: application/simple-message-summary
DNS SRV lookup: No
Pedantic SIP support: Yes
Reg. min duration 60 secs
Reg. max duration: 3600 secs
Reg. default duration: 120 secs
Outbound reg. timeout: 20 secs
Outbound reg. attempts: 0
Notify ringing state: Yes
Include CID: No
Notify hold state: Yes
SIP Transfer mode: open
Max Call Bitrate: 384 kbps
Auto-Framing: No
Outb. proxy:
Session Timers: Accept
Session Refresher: uas
Session Expires: 1800 secs
Session Min-SE: 90 secs
Timer T1: 500
Timer T1 minimum: 100
Timer B: 32000
No premature media: Yes
Max forwards: 70

Default Settings:

Allowed transports: UDP
Outbound transport: UDP
Context: from-sip-external
Force rport: Yes
DTMF: rfc2833
Qualify: 2000
Use ClientCode: No
Progress inband: Never
MOH Interpret: default
MOH Suggest:
Voice Mail Extension: *97

Is the external address and localnet as displayed correct?

Everything you need to know can be found by clicking on this link: