FreePBX | Register | Issues | Wiki | Portal | Support

I am lost. Newbie needs help!


(Sse450) #1

I have installed the latest FreePBX distro with FreePBX 14.0.11 and Asterisk 13.22.0. It is working nicely.

I signed up with a trunk provider and obtained the credentials. Entered these data in Connectivity | Trunks. Also entered register string in the incoming. I made chan_sip port as 5060, pfsip as 5160. My FreePBX connects to the SIP trunk provider as seen in the Reports | Asterisk Info | Registries:
12.123.123.24:5060 N 902124000212 285 Registered Tue, 14 May 2019 18:41:10
Created some Outbound patterns in Connectivity | Outbound Route. To me, so far, so good.

My problem starts here: I cannot register any phone to my FreePBX. I have a Yealink T29G. IP of my FreePBX is 10.10.1.20. I try to register the phone using 10.10.1.20:5060. No way! Web page of the phone says “Register Failed”.

Chan_Sip Peers:
Name/username Host Dyn Forcerport Comedia ACL Port Status Description
200 (Unspecified) D No No A 0 UNKNOWN
201 (Unspecified) D No No A 0 UNKNOWN
202 (Unspecified) D No No A 0 UNKNOWN
xyzTelecom/902124000 12.123.123.24 Yes Yes 5060 OK (4 ms)
4 sip peers [Monitored: 1 online, 3 offline Unmonitored: 0 online, 0 offline]

Furthermore, I noticed something on Dashboard. System overview box says Default bind port for CHAN_PJSIP is: 5060, CHAN_SIP is: 5160 although the bind port is 5060 on Settings | Asterisk SIP settings | ChanSIP settings.

What gives? What am I doing wrong? It is quite possible that I misunderstand the setup process.

I would appreciate any help.


#2

Confirm that your PBX is on-site and on a physical machine. If cloud or virtual, provide details.

Confirm that in Asterisk SIP Settings, you have:
External Address: (your public IPv4 address)
Local Networks: 10.10.1.0 / 24
Chan SIP Bind Port: 5060
Chan PJSIP Port to Listen On: 5160

If you change any of these, you must restart (not just reload) Asterisk.

Confirm that extension 200 Type is ‘sip’ and that Yealink’s IP address is in 10.10.1.0/24 subnet.

In Yealink for extension 200, confirm:
Line Active: Enabled
Register Name: 200
User Name: 200
Password: (matches secret for extension)
NAT: Disabled
SIP Server 1 Server Host: 10.10.1.20
SIP Server 1 Port: 5060

If no luck, try disabling FreePBX Firewall:
fwconsole firewall disable

If still no luck, what, if anything, appears in Asterisk log when Yealink attempts to register?


(Sse450) #3

Using all the hints you provided, I found out that 10.10.20.0/24 cannot reach SIP server (10.10.1.20) due to a block rule in pfSense. As soon as I correct it, all my 3 phones are registered.

I am grateful for your help after so much fruitless struggling. Thank you.


(system) closed #4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.