Hyper-V Integrated Services (VSS deamon)

Hello,

I’m wondering if anyone can help guide me regarding the use of integrated services for Hyper-V on the current release of the FreePBX distro. It appears FreePBX is still using CentOS 6.6 as a base. I believe CentOS had integrated services bundled with it, but they are relatively old now.

Can we upgrade/install integrated services for Hyper-V without problems?

The reason I’m curious is I’m trying to use windows server backup on the Hyper-V host to perform VM level backups of all guest VM’s. The FreePBX VM is failing to perform an online backup even though the VM is advertising itself as capable of online backup to windows server backup. This should be possible as long as the hv_vss_deamon is running inside the linux VM. And I believe CentOS 6.6 supports this, but I can’t seem to find it running or even available.

Some background HERE.

Querying to see if integrated services are available:

[[email protected]]# lsmod | grep hv_utils
hv_utils               14856  0
hv_vmbus              246218  7  hv_netvsc,hv_utils,hv_balloon,hid_hyperv,hyperv_keyboard,hv_storvsc,hyperv_fb

And checking to see if deamons are running:

[[email protected]]# ps -ef | grep hv
root       126     2  0  2016 ?        00:00:00 [hv_vmbus_con/0]
root       127     2  0  2016 ?        00:00:00 [hv_vmbus_con/1]
root       541     2  0  2016 ?        00:03:10 [hv_balloon]
root     11900  9647  0 09:59 pts/0    00:00:00 grep hv

And from here I can’t even find that the VSS deamon is available to start.

So I figured out that I need to run

yum install hyperv-deamons

to get the “approved” ones installed for the current OS version. Some reason I thought these were already installed by default. I assume I could force an install of the latest versions but I don’t really need that. Will see tonight if backups work now that I’ve enabled the VSS deamon;

Install hyperv-deamons;

[[email protected]]# yum list installed hyperv-deamons
Loaded plugins: fastestmirror, kmod
Loading mirror speeds from cached hostfile
Error: No matching Packages to list
[[email protected] jgould]# yum install hyperv-daemons
Loaded plugins: fastestmirror, kmod
Setting up Install Process
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package hyperv-daemons.x86_64 0:0-0.15.20130826git.el6 will be installed
--> Processing Dependency: hypervvssd = 0-0.15.20130826git.el6 for package: hyperv-daemons-0-0.15.20130826git.el6.x86_64
--> Processing Dependency: hypervkvpd = 0-0.15.20130826git.el6 for package: hyperv-daemons-0-0.15.20130826git.el6.x86_64
--> Processing Dependency: hypervfcopyd = 0-0.15.20130826git.el6 for package: hyperv-daemons-0-0.15.20130826git.el6.x86_64
--> Running transaction check
---> Package hypervfcopyd.x86_64 0:0-0.15.20130826git.el6 will be installed
--> Processing Dependency: hyperv-daemons-license = 0-0.15.20130826git.el6 for package: hypervfcopyd-0-0.15.20130826git.el6.x86_64
---> Package hypervkvpd.x86_64 0:0-0.15.20130826git.el6 will be installed
---> Package hypervvssd.x86_64 0:0-0.15.20130826git.el6 will be installed
--> Running transaction check
---> Package hyperv-daemons-license.noarch 0:0-0.15.20130826git.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================================================================================================================================
Package                                                     Arch                                        Version                                                     Repository                                 Size
=====================================================================================================================================================================================================================
Installing:
hyperv-daemons                                              x86_64                                      0-0.15.20130826git.el6                                      base                                      3.2 k
Installing for dependencies:
hyperv-daemons-license                                      noarch                                      0-0.15.20130826git.el6                                      base                                       11 k
hypervfcopyd                                                x86_64                                      0-0.15.20130826git.el6                                      base                                      8.3 k
hypervkvpd                                                  x86_64                                      0-0.15.20130826git.el6                                      base                                       17 k
hypervvssd                                                  x86_64                                      0-0.15.20130826git.el6                                      base                                      8.9 k

Transaction Summary
=====================================================================================================================================================================================================================
Install       5 Package(s)

Total download size: 48 k
Installed size: 67 k
Is this ok [y/N]: y
Downloading Packages:
(1/5): hyperv-daemons-0-0.15.20130826git.el6.x86_64.rpm                                                                                                                                       | 3.2 kB     00:00
(2/5): hyperv-daemons-license-0-0.15.20130826git.el6.noarch.rpm                                                                                                                               |  11 kB     00:00
(3/5): hypervfcopyd-0-0.15.20130826git.el6.x86_64.rpm                                                                                                                                         | 8.3 kB     00:00
(4/5): hypervkvpd-0-0.15.20130826git.el6.x86_64.rpm                                                                                                                                           |  17 kB     00:00
(5/5): hypervvssd-0-0.15.20130826git.el6.x86_64.rpm                                                                                                                                           | 8.9 kB     00:00
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                                                 61 kB/s |  48 kB     00:00
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
   Installing : hyperv-daemons-license-0-0.15.20130826git.el6.noarch                                                                                                                                              1/5
   Installing : hypervkvpd-0-0.15.20130826git.el6.x86_64                                                                                                                                                          2/5
   Installing : hypervfcopyd-0-0.15.20130826git.el6.x86_64                                                                                                                                                        3/5
   Installing : hypervvssd-0-0.15.20130826git.el6.x86_64                                                                                                                                                          4/5
   Installing : hyperv-daemons-0-0.15.20130826git.el6.x86_64                                                                                                                                                      5/5
   Verifying  : hyperv-daemons-license-0-0.15.20130826git.el6.noarch                                                                                                                                              1/5
   Verifying  : hyperv-daemons-0-0.15.20130826git.el6.x86_64                                                                                                                                                      2/5
   Verifying  : hypervkvpd-0-0.15.20130826git.el6.x86_64                                                                                                                                                          3/5
   Verifying  : hypervfcopyd-0-0.15.20130826git.el6.x86_64                                                                                                                                                        4/5
   Verifying  : hypervvssd-0-0.15.20130826git.el6.x86_64                                                                                                                                                          5/5

Installed:
   hyperv-daemons.x86_64 0:0-0.15.20130826git.el6

Dependency Installed:
   hyperv-daemons-license.noarch 0:0-0.15.20130826git.el6       hypervfcopyd.x86_64 0:0-0.15.20130826git.el6       hypervkvpd.x86_64 0:0-0.15.20130826git.el6       hypervvssd.x86_64 0:0-0.15.20130826git.el6

Complete!

Check if available;

[[email protected]]# compgen -c hv_
hv_vss_daemon
hv_fcopy_daemon
hv_kvp_daemon

Start daemon;

[[email protected]]# hv_vss_daemon

Check if running;

[[email protected]]# ps -ef | grep hv
root       126     2  0  2016 ?        00:00:00 [hv_vmbus_con/0]
root       127     2  0  2016 ?        00:00:00 [hv_vmbus_con/1]
root       541     2  0  2016 ?        00:03:10 [hv_balloon]
root     13178     1  0 10:19 ?        00:00:00 hv_vss_daemon
root     13181  9647  0 10:19 pts/0    00:00:00 grep hv
3 Likes

Can confirm that the backups worked last night. :slight_smile:

Nice - Adding this to my list of things to do…

You might want to fix the post - you have

“yum install hyperv-deamons”

Should Be:

“yum install hyperv-daemons”

1 Like

nice post! worked for me… I don’t understand why VSS daemon is not installed and running by default.

Why would we install it by default. We have no way of knowing how your installing a system and we only install the basics for what the PBX requires.

1 Like

I cannot see why not! virtualization is not the future anymore it is where we already are.

Why would we install something that very few people use. Your missing the point here. It’s in the repo doe you to install. Why would we install it on every system when less then 1% use hyper V with FreePBX.