HTTPS certs not installing from the HTTPS setup page

Trying to get HTTPS to work.
I have created a Let’s Encrypt and a self-signed certificates using the certificate management page. Then I go to system admin and HTTPS setup. Under setting select one of the certificates and press install. The trouble is the cert is never uploaded to Apache and Apache Config: No Certificate in Apache Config.
Any ideas what I’m doing wrong?

So I purchased a real cert and is worked just find

But how can it be solved with self-signed cert? I have this issue too.

I was having a similar issue where apache wouldn’t install the cert, a complete restart ended up letting it install.

I did this too but didn’t solve the issue!

what version are you on? there were a bunch of issues but the latest version seems to have fixed them

Latest. I did an update today morning too.

Same problem here on a brand new install.

I created a letsencrypt cert, click install and nothing happend.

What did you expect to happen?

That it install the certificate on apache.

Looks like a change was made in sysadmin that corrected this.

I’m on Just did a check online, but is not available. Is there another way to download

It’s in edge. You need to switch to edge mode in advanced settings.

Perfect… I just upgraded to edge) and now it worked :smiley:

Thank you for the help. Next time before opening a ticket I’ll check latest edge version! :slight_smile:

Another thing @tm1000, certificate chain using SSLCertificateFile only works on apache 2.4.8. This made the certificate not being validated by the browsers.

Apache documentation says:

The files may also include intermediate CA certificates, sorted from leaf to root. This is supported with version 2.4.8 and later, and obsoletes SSLCertificateChainFile. When running with OpenSSL 1.0.2 or later, this allows to configure the intermediate CA chain on a per-certificate basis.

Freepbx now, is using httpd-2.2.15-31. I think you should split the CA to SSLCertificateChainFile until you have freepbx using apache >=2.4.8 (RHEL7).

1 Like

Fixes for what you propose are now in: sysadmin v13.0.63.5 and certman v13.0.28

It’ll require you to go to certman and update said certificate and then go to sysadmin and install certificate.

Very helpful. Thank you!

But still I have the issue…
with this update I can’t make calls via http/firefox too (sslv3 bad certificate)

It’s always been broken for you so I fail to see how this is any different…furthermore this change is for chain files only. It does not apply to self signed cert (which have no chain files)

It’s also working fine for many other people.

Yes I’m from Mars :slight_smile: