FreePBX | Register | Issues | Wiki | Portal | Support

Http(s) provisioning password set automatically, but cant remove or change and i dont know what it is


(United States) #1

Good morning,

I am provisioning a new server and told the provisioning services to auto create a user/pass for the http auto provisioning. It apparently did so, then refused to share them with me and still show as disabled in the provisioning section of the system admin. I cannot remove these in any way that i have found so far, and google and forum search have netted me 0 results for this. Can anyone point me in the direction i need to go to remove this so i can get this to work?


(Lorne Gaetz) #2

If credentials are showing as disabled in Admin, System Admin, Provisioning Protocols, then there should be no apache credentials. How have you determined that credentials are enabled, are you seeing response 401 from the PBX when you attempt to download something?


(United States) #3

I get a 401 response in the log of the phone system as well as when i attempt to browse directly i get a prompt for a user/pass. As i am a new user, i cannot post links. This is the screenshot of the error. Pretty sure i’ve discovered a bug. its a small system, will not take me long to rebuild it if i am unable to remove this. Verified it on a second build. If you click generate password and dont have the pro version, it generates a user/pass but does not give it to you.


(Rob Thomas) #4

That sounds like a bug and you should open a ticket. However, to get the credentials, you can run this command from the shell:

mysql asterisk -e 'select * from sysadmin_options where `key` like "provis%"'

You’ll get three lines back, the names should be self explanatory 8)

I’m ALSO reasonably certain that they’re displayed in Endpoint Manager too - even the free version.


(Jared Busch) #5

They are.


(system) closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.