HTTP Provisioning Yealink

Hello Forum,

I’m having a couple of problems with the endpoint manager module that’s driving me crazy…
Hoping someone can lend a hand.

Phones are Yealink T38G

  1. Endpoint manager – image management
    Imagemagick is installed, logo is png, size is 107kb.
    No indication why it fails, I choose file and choose upload image but image fails to upload.
  2. I’m having a struggle getting http provisioning working. I have created an extension, created a template with line key info and selected http provisioning and mapped the phone to the extension. I’m able to reboot the phone from the extension mapping section in endpoint. On the yealink “auto provision” tab I have added the PBX server ip and also tried several variation of the url. The HTTP Provisioning port is port 84.

This possibly answers my first issue:

Problem No 2 solved -
Create the directory /tftpboot and add the correct folder permission.

Can anyone advise me on the location the image folder should reside for uploaded phone logo’s?
Should it be /tftpboot/images?

Answer to No 1.

After a painfully long time it would appear that endpoint manager not only failed to create the /tftpboot directory but also the image folder. This folder appeared in the /tftpboot directory after uninstalling and re-installing the module. Creating the non-existent image folder and adding the permissions still failed to upload images.
Hope this helps anyone that’s ends up in the same situation, as I spent quite a few hours searching forums but failed to find an answer.