.htaccess files are disabled on this webserver: what verifications does FreePBX for this?

Hi all!

I’m getting the following message on the dashboard of FreePBX:

.htaccess files are disabled on this webserver. Please enable them

I think this message was shown twice.

After have added the AllowOverride All directive in the Apache virtual host, one of the messages disappeared. But still is showing one of them. What verification does FreePBX that still being displayed this message?

Thanks in advance.

Kind regards,
Daniel

if ( !isset($_SERVER['HTACCESS']) && preg_match("/apache/i", $_SERVER['SERVER_SOFTWARE'])) {

did you restart apache

Hi, James.

Thanks for your reply.

Yes, I do. These are the AllowOverride directives I have in my Apache configuration files (on Debian Jessie):

[email protected]:/etc/apache2# grep -R AllowOverride * | grep -v :# | grep -v available
apache2.conf:   AllowOverride None
apache2.conf:   AllowOverride None
apache2.conf:   AllowOverride None
conf-enabled/serve-cgi-bin.conf:                        AllowOverride None
mods-enabled/alias.conf:                AllowOverride None
sites-enabled/pbxtest.freesoftware.conf:                AllowOverride All

The latter is the one for the virtualhost of FreePBX.

I was reviewing the three directives in apache.conf:

<Directory />
       Options FollowSymLinks
       AllowOverride None
       Require all denied
</Directory>

<Directory /usr/share>
       AllowOverride None
       Require all granted
</Directory>

<Directory /var/www/>
       Options Indexes FollowSymLinks
       AllowOverride None
       Require all granted
</Directory>

I’ve tried changing the AllowOverride of /var/www and restarting Apache, but no changes.

Any advice will be appreciated.

Kind regards,
Daniel

Any help is welcome. If more information is needed, please let me know.

Thanks in advance.

Kind regards,
Daniel