HP Microserver/SNG7-FPBX-64bit-1707-1 - installation fails

I’m trying to install on a HP Microserver N40 with latest BIOS. The system has 8Gbyte memory and currently only has a single 250Gbyte HD. The BIOS is configured for IDE HDs. I can install SME Server (Ver 9.2) on the same system without trouble but the graphical interface of Freepbx cannot find the disk. The disk has been tested with seagate s/w and passes all tests.

First off, is the system compatible with SNG7-FPBX-64bit-1707-1? If it is where do go from here?

Can you tell us exactly which “not found” error you are getting? It could be a driver problem with the IDE controller. Also, when you get done booting up, try the “dmesg” command and see what controllers and drives the system finds during bootup.

The message at the bottom of the screen reads: “No disks detected Please shutdown the computer, connect at least one drive, and restart the complete installation”

I have pictures of the screen if it helps.

Maybe I’m being dumb but I can not see how I run the dmesg command without an O/S unless I do it usint the installed and working copy of SME Server.


Sounds like you need the drivers for your raid controller.

I had this problem years ago with debian on a gen6 server. Maybe you find drivers you can attach via usb stick during install.

Do I assume that the HP Microservers are not compatible with this and future versions of Freepbx?

Are you installing from USB?
If you are try from a DVD, I had a lot of problems with a USB including HDD issue until I booted from a DVD, then it worked first time.

I’ve tried both but most of my attempts have been using a DVD. I’m probably doing something wrong but writing the ISO to a USB stick using Win32Imagewriter did not produce a bootable device.

Go into the setup of the server and change the SATA device type from the RAID system that HP uses as their default to one of the “older” technologies and try one more time. To me, it sounds like you are in need of a driver as well, but getting the software installed on a disk that you don’t have a driver for is like lifting yourself by your hair.


I’ve tried with RAID, AHCI and IDE. All give the same result. :frowning:


Read this

Unfortunately the set up in the article was nothing like mine and I have completely abandoned attempts to get this software to work on the N40L server. It maybe operator error or faulty hardware but everything I have tried has failed.

I am currently building the system on a dual-core system which appears to work happily.

Thanks for the help and advice.