How to troubleshoot registration problems


I am new to asterisk and freePBX, but I am trying to learn as fast as I can.

I installed the PBXin a flash version of asterisk and freePBX and I am using freePBX to try to configure my pbx.

I have sucessfully installed a sipura 2000 as 1 extension and a softphone as a second extension. I am able to call from one extension to another.

I am now trying to install a trunk to register with my Broadvoice account. I must have tried dozens of diff configuration and registration strings and nothing seems to work.

My question is not what configurations work, but how do I go about troubleshooting this?

1)Is there any simple way to see if the trunk registered? ( I have been calling broadvoice to see if I am registered, but that is very time consuming)

2) Is there some way of seeing where the problem is?

Any help would be appreciated.


OK , I’m about ready to give up.

I’ve tried every suggestion I can read on all the forums and I still believe there is something wrong with my asterisk setup.

I’ve put my asterisk server on DMZ and still no go.

If anyone would be knind enough to ssh into my system and look at my setup maybe they can easily spot where I’m having trouble.

If anyone would like to try just email me at [email protected] and I’ll send you the login/password info.

Thanks in advance


Anyone willing to try?



Since this worked and then quit, why don’t you try replacing your router. I have sip trunks hooked to my machine and yet yours would not register the other night. I have had a router fail that caused similar symptoms.

I’m not sure you understand the situation.

I never got it to register with an outside sip trunk.

I have installed some extensions internally, which can call one another , but I can’t connect to an outside trunk.

I can’t be sure what the problem is. I put my asterisk in DMZ mode, and have everything installed properly ( I believe) but it just doesn’t seem to register at all to outside trunks

Can you get IAX2 trunks to register remotely?

Given this information, I would look very hard at the router/firewall. Some of them just won’t work. What model router are you using?

I haven’t tried the IAX2 trunks yet.

I have tired this with Netgear 854T as well as lynksys WRT54GX2.

I am pretty sure there is something in my asterisk installation. I don’t even see anything in the router logs showing attempts at registration.


Voicepulse posted a good newbie guide to the Trixbox forums about 5 weeks ago
a good guide using wireshark to cap the traffic and then wireshark on a PC to view the file

the local way is

the cmd ngrep -d any -Wbyline -t port 5060 will watch the port

ngrep -d any -Wbyline -t port 5060 >portcap.txt will write it out to a file

first step is to get proper configuration information from your provider as each provider tends to have different requirements. As far as seeing if you are registered: “sip show registry” will do it.

I have the proper config setup from provider, but when I call the provider they claim they are not seeing any attempts to register from my ip address.

I assume it has something to do with firewall? I followed the instructions to the letter from pbx in a flash , but I get only internal extensions working and I can’t seem to get any external communication going.

I have had problems with Broadvoice in the past. Their tech support is almost non-existent and they are no help when configuring Asterisk. I like a lot better.

That being said, you should not need any ports open on you firewall, unless it is blocking outbound traffic. You could open UDP 5060-5082 and UDP 10000-20000, which are the standard SIP ports, but I doubt that will make much difference. If you have external extensions on your system, you will need to open these ports.

Make sure you have some entries in sip_nat.conf similar to these: ; your fixed external IP address ;Your internal subnet/subnet mask

If you don’t have a fixed IP address, it should look like this: ;like
externrefresh=300 ;number of seconds until a renew of dyndns occurs ;Your internal subnet/subnet mask

If you don’t have a dynamic dns name, you can get one free from Most inexpensive SOHO routers have a screen on them to register with the provider.

Thanks for the replies,

I have dynamic dns set up as

I have sip_nat.conf as follows
localnet= /

my asterisk server is on a local net with an ip address of
my router is set to forward all sip ports to the asterisk server,

I have all the configurations set for Broadvoice , but when I start or load asterisk nothing seems to register?

any suggestions as to how to trouble shoot this?


I have the same issue for the past few days. The weird thing is that my configuration is definately correct because the trunk has worked since November. For some reason ever since May 16th the trunk just stopped registering with Broadvoice. I created a new trunk with the same config and still nothing. When I spoke to Broadvoice they id that my server isn’t sending our any requests since the 16th. I have other inbound trunks that are registering so I’m sure it’s not my server or connection. But Broadvoice insists that it is on my side. I’m wondering if there is an issue with their ever that they are unaware of.

This is why I left Broadvoice a couple of years ago. The exact same thing happened to me. It is probably on their end, but they will never admit it.

I,m not sure if I can be sure the problem is with Broadvoice or with my asterisk setup.

Is there any type of test Voip host that I can check to see if my asterisk registers? I really do not feel like signing up to diff hosts with my credit card and then get caught in billing nightmares.

Is there any type of test I can run to see if my asterisk is doing its side of sip correctly?


Anyone? This is driving me crazy.

Is there any log or error trapping that might tell me where the problem is?

I have even tried running the router in DMZ mode and I can’t get asterisk to register to 2 diff VOIP providers, so I think I have
a problem with my asterisk installation, but how do I figure out what it is?

Any help would be gratly appreciated.



Call me. I will be up until 9:30 pm Eastern US time. I have set up a SIP trunk to here to test with.

secret=you will have to call me for this

registration joetest:[email protected] is not good–they do not allow you to port out DIDs. One way I got out from BroadVoice service with intrupuction of my business is to set the BroadVoice DID to immediate answer calls. In the announcement, I told callers that my phone number has changed or press “0” to get connected to the new phone number. It takes me a year to finally switch out. collects ~$8/month FCC fees. but Broadvoice does not honor FCC regulations on number porting. A bad business.

I am using Aastra 57I phones and Polycom 501. I have set up my extensions. However cannot get them to register. It seems there are several places for user names and passwords for each type of phone.
Which are the correct entrys. My extension is 112 that is the user name correct? My secret is 1111 that is the password. Please advise.